Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 597159 - Protocol icq not found
Summary: Protocol icq not found
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: empathy
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-28 09:43 UTC by Julian Leyh
Modified: 2010-05-29 11:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-29 11:48:26 UTC


Attachments (Terms of Use)

Description Julian Leyh 2010-05-28 09:43:22 UTC
Description of problem:
after entering ICQ login and pressing 'connect', it doesn't connect.
on the first start using the wizard, a message popped up with "Protocol icq not found".
using account editor, it just doesn't connect.
with EMPATHY_DEBUG=all set, i get "Protocol icq not found" in debug messages.

Version-Release number of selected component (if applicable):
empathy 2.28.2

How reproducible:
create new icq account, enter login details and click on 'connect'

Additional info:

output of EMPATHY_DEBUG=all, from the moment i click on 'connect':

(empathy:12172): empathy-DEBUG: account_widget_applied_cb: Could not apply changes to account: Protocol icq not found
(empathy:12172): tp-glib/proxy-DEBUG: noc_idle_context_invoke: NameOwnerChanged(org.freedesktop.Telepathy.ConnectionManager.haze,  -> :1.229)
(empathy:12172): tp-glib/proxy-DEBUG: noc_idle_context_invoke: NameOwnerChanged(org.freedesktop.Telepathy.ConnectionManager.haze,  -> :1.229)
(empathy:12172): tp-glib/proxy-DEBUG: noc_idle_context_invoke: NameOwnerChanged(org.freedesktop.Telepathy.AccountManager, :1.224 -> )
(empathy:12172): empathy-DEBUG: account_manager_name_owner_cb: Name owner changed for org.freedesktop.Telepathy.AccountManager, new name: 
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_borrow_interface_by_id: 0x273f0c0: org.freedesktop.DBus.Peer DBusGProxy is 0x27a22e0
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_dispose: 0x273f0c0
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_invalidate: 0x273f0c0: Proxy unreferenced
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_finalize: 0x273f0c0
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_dispose: 0x20f4240
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_invalidate: 0x20f4240: Proxy unreferenced
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_signal_connection_proxy_invalidated: 0x2608160: TpProxy 0x20f4240 invalidated (I have 0x20f4240): Proxy unreferenced
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_signal_connection_proxy_invalidated: 0x2627710: TpProxy 0x20f4240 invalidated (I have 0x20f4240): Proxy unreferenced
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_signal_connection_lost_weak_ref: 0x2627710: lost weak ref to 0x20f4240
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_finalize: 0x20f4240
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_dispose: 0x20f4360
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_invalidate: 0x20f4360: Proxy unreferenced
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_signal_connection_proxy_invalidated: 0x26db200: TpProxy 0x20f4360 invalidated (I have 0x20f4360): Proxy unreferenced
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_signal_connection_proxy_invalidated: 0x26db270: TpProxy 0x20f4360 invalidated (I have 0x20f4360): Proxy unreferenced
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_signal_connection_lost_weak_ref: 0x26db270: lost weak ref to 0x20f4360
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_finalize: 0x20f4360
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_dispose: 0x2086c90
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_invalidate: 0x2086c90: Proxy unreferenced
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_signal_connection_proxy_invalidated: 0x26db0b0: TpProxy 0x2086c90 invalidated (I have 0x2086c90): Proxy unreferenced
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_signal_connection_proxy_invalidated: 0x26d9580: TpProxy 0x2086c90 invalidated (I have 0x2086c90): Proxy unreferenced
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_signal_connection_lost_weak_ref: 0x26db0b0: lost weak ref to 0x2086c90
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_finalize: 0x2086c90
(empathy:12172): tp-glib/proxy-DEBUG: noc_idle_context_invoke: NameOwnerChanged(org.freedesktop.Telepathy.AccountManager, :1.224 -> )
(empathy:12172): tp-glib/proxy-DEBUG: noc_idle_context_invoke: NameOwnerChanged(org.freedesktop.Telepathy.AccountManager,  -> :1.230)
(empathy:12172): empathy-DEBUG: account_manager_name_owner_cb: Name owner changed for org.freedesktop.Telepathy.AccountManager, new name: :1.230
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_borrow_interface_by_id: 0x2772330: org.freedesktop.Telepathy.AccountManager DBusGProxy is 0x26db040
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_borrow_interface_by_id: 0x2772330: org.freedesktop.DBus.Properties DBusGProxy is 0x26db190
(empathy:12172): tp-glib/proxy-DEBUG: noc_idle_context_invoke: NameOwnerChanged(org.freedesktop.Telepathy.AccountManager,  -> :1.230)
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_borrow_interface_by_id: 0x20f4360: org.freedesktop.Telepathy.Account DBusGProxy is 0x2608080
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_borrow_interface_by_id: 0x20f4360: org.freedesktop.DBus.Properties DBusGProxy is 0x27e72d0
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_borrow_interface_by_id: 0x20f4240: org.freedesktop.Telepathy.Account DBusGProxy is 0x27e74b0
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_borrow_interface_by_id: 0x20f4240: org.freedesktop.DBus.Properties DBusGProxy is 0x273b470
(empathy:12172): tp-glib/accounts-DEBUG: _tp_account_got_all_cb: Got whole set of properties for /org/freedesktop/Telepathy/Account/gabble/jabber/oenone_40jabber_2eorg0
(empathy:12172): tp-glib/accounts-DEBUG: _tp_account_got_all_cb: Got whole set of properties for /org/freedesktop/Telepathy/Account/gabble/jabber/oenone_40jabber_2eorg0
(empathy:12172): tp-glib/accounts-DEBUG: _tp_account_got_all_cb: Got whole set of properties for /org/freedesktop/Telepathy/Account/gabble/jabber/oenone_40jabber_2eccc_2ede0
(empathy:12172): tp-glib/accounts-DEBUG: _tp_account_got_all_cb: Got whole set of properties for /org/freedesktop/Telepathy/Account/gabble/jabber/oenone_40jabber_2eccc_2ede0
(empathy:12172): empathy-DEBUG: empathy_account_got_all_cb: Got whole set of properties for /org/freedesktop/Telepathy/Account/gabble/jabber/oenone_40jabber_2eorg0
(empathy:12172): empathy-DEBUG: emp_account_manager_update_global_presence: Updated global presence to: available (2) ""
(empathy:12172): empathy-DEBUG: idle_presence_changed_cb: Presence changed to 'available' (2) ""
(empathy:12172): empathy-DEBUG: empathy_account_got_all_cb: Got whole set of properties for /org/freedesktop/Telepathy/Account/gabble/jabber/oenone_40jabber_2eccc_2ede0
(empathy:12172): empathy-DEBUG: idle_presence_changed_cb: Presence changed to '(null)' (1) "(null)"
(empathy:12172): empathy-DEBUG: idle_presence_changed_cb: Presence changed to 'available' (2) ""
(empathy:12172): empathy-DEBUG: accounts_dialog_destroy_cb: 0x21731c0
(empathy:12172): empathy-DEBUG: user_data_destroyed_cb: user_data for 0x277d040 destroyed; disconnecting
(empathy:12172): empathy-DEBUG: user_data_destroyed_cb: user_data for 0x2767c60 destroyed; disconnecting
(empathy:12172): tp-glib/proxy-DEBUG: _tp_dbus_daemon_stop_watching: Removing match rule type='signal',sender='org.freedesktop.DBus',path='/org/freedesktop/DBus',interface='org.freedesktop.DBus',member='NameOwnerChanged',arg0='org.freedesktop.Telepathy.ConnectionManager.gabble'
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_dispose: 0x261abe0
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_invalidate: 0x261abe0: Proxy unreferenced
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_finalize: 0x261abe0
(empathy:12172): tp-glib/proxy-DEBUG: _tp_dbus_daemon_stop_watching: Removing match rule type='signal',sender='org.freedesktop.DBus',path='/org/freedesktop/DBus',interface='org.freedesktop.DBus',member='NameOwnerChanged',arg0='org.freedesktop.Telepathy.ConnectionManager.salut'
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_dispose: 0x261aa60
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_invalidate: 0x261aa60: Proxy unreferenced
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_finalize: 0x261aa60
(empathy:12172): tp-glib/proxy-DEBUG: _tp_dbus_daemon_stop_watching: Removing match rule type='signal',sender='org.freedesktop.DBus',path='/org/freedesktop/DBus',interface='org.freedesktop.DBus',member='NameOwnerChanged',arg0='org.freedesktop.Telepathy.ConnectionManager.idle'
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_dispose: 0x261ad60
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_invalidate: 0x261ad60: Proxy unreferenced
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_finalize: 0x261ad60
(empathy:12172): tp-glib/proxy-DEBUG: _tp_dbus_daemon_stop_watching: Removing match rule type='signal',sender='org.freedesktop.DBus',path='/org/freedesktop/DBus',interface='org.freedesktop.DBus',member='NameOwnerChanged',arg0='org.freedesktop.Telepathy.ConnectionManager.butterfly'
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_dispose: 0x261ab20
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_invalidate: 0x261ab20: Proxy unreferenced
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_finalize: 0x261ab20
(empathy:12172): tp-glib/proxy-DEBUG: _tp_dbus_daemon_stop_watching: Removing match rule type='signal',sender='org.freedesktop.DBus',path='/org/freedesktop/DBus',interface='org.freedesktop.DBus',member='NameOwnerChanged',arg0='org.freedesktop.Telepathy.ConnectionManager.haze'
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_dispose: 0x261aca0
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_invalidate: 0x261aca0: Proxy unreferenced
(empathy:12172): tp-glib/proxy-DEBUG: tp_proxy_finalize: 0x261aca0

Comment 1 Julian Leyh 2010-05-29 11:48:26 UTC
after update (didn't seem to touch anything related to this problem) and reboot, it worked, after clicking a couple of times on 'connect'...

so i can't reproduce any more, seems to have been a single problem.


Note You need to log in before you can comment on or make changes to this bug.