Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 597145 - guestfish 'help' command should indicate error in exit status with an unknown command
Summary: guestfish 'help' command should indicate error in exit status with an unknown...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libguestfs
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 598771 598772
TreeView+ depends on / blocked
 
Reported: 2010-05-28 08:54 UTC by Jinxin Zheng
Modified: 2011-07-14 19:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 598771 598772 (view as bug list)
Environment:
Last Closed: 2011-07-14 19:12:24 UTC


Attachments (Terms of Use)

Description Jinxin Zheng 2010-05-28 08:54:40 UTC
Description of problem:
Issueing the 'help' command in guestfish with an unknown command name exits 
with a 0 exit code.

Version-Release number of selected component (if applicable):
guestfish 1.3.17

How reproducible:
Always

Steps to Reproduce:
1. guestfish help foo
2. echo $?
3.
  
Actual results:
the exit status of guestfish is 0

Expected results:
supposed to be some other than 0 to indicate an error.

Additional info:
I wanted to use help to test the availability of some new commands in a script, 
finding that it's impossible to determine only from the exit status of guestfish.
Therefore I must test the stderr in order to work the result out.

Comment 1 Richard W.M. Jones 2010-06-01 15:31:26 UTC
Patch posted upstream:
https://www.redhat.com/archives/libguestfs/2010-June/msg00013.html

Please clone this bug if you want this in RHEL 5/6.  It's a relatively
simple change to backport.

Comment 2 Jinxin Zheng 2010-06-02 02:18:46 UTC
(In reply to comment #1)
> Patch posted upstream:
> https://www.redhat.com/archives/libguestfs/2010-June/msg00013.html
> 
> Please clone this bug if you want this in RHEL 5/6.  It's a relatively
> simple change to backport.    

Cloned as #598771 and #598772 since this is a simple change.

Comment 3 Fedora Update System 2010-06-02 21:12:24 UTC
libguestfs-1.2.9-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/libguestfs-1.2.9-1.el5

Comment 4 Fedora Update System 2010-06-02 21:26:10 UTC
libguestfs-1.2.9-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libguestfs-1.2.9-1.fc13

Comment 5 Fedora Update System 2010-06-03 08:48:49 UTC
libguestfs-1.2.9-1.el5.1 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/libguestfs-1.2.9-1.el5.1


Note You need to log in before you can comment on or make changes to this bug.