Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 597114 - [Java] CJK font name paths are no longer valid
Summary: [Java] CJK font name paths are no longer valid
Keywords:
Status: CLOSED DUPLICATE of bug 643674
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: jiri vanek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-28 07:06 UTC by Ding-Yi Chen
Modified: 2010-11-29 06:58 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-03 14:56:11 UTC


Attachments (Terms of Use)
Patch for fontconfig.Fedora.properties (deleted)
2010-05-28 07:06 UTC, Ding-Yi Chen
no flags Details

Description Ding-Yi Chen 2010-05-28 07:06:48 UTC
Created attachment 417496 [details]
Patch for fontconfig.Fedora.properties

Description of problem:
In Fedora 13, the original path for two chinese fonts:  
filename.AR_PL_ShanHeiSun_Uni=/usr/share/fonts/chinese/TrueType/uming.ttf
filename.AR_PL_ZenKai_Uni=/usr/share/fonts/chinese/TrueType/ukai.ttf

are no longer valid.

For Traditional Chinese users (chinese-big5),
AR PL ShanHeiSun Uni should be replaced by AR PL UMing HK
AR PL ZenKai Uni should be replaced by AR PL UKai HK

Simplified Chinese seems preferred WenQuanYi Zen Hei,
thus it should be used in chinese-gb18030.

Paths for these fonts.
filename.AR_PL_UMing_HK=/usr/share/fonts/cjkuni-uming/uming.ttc
filename.AR_PL_UKai_HK=/usr/share/fonts/cjkuni-ukai/ukai.ttc
filename.WenQuanYi_Zen_Hei=/usr/share/fonts/wqy-zenhei/wqy-zenhei.ttc


Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-1.6.0.0-37.b17.fc13.i686


How reproducible:
Always

Proposed patch is attached.

Comment 1 Deepak Bhole 2010-08-19 21:26:03 UTC
Please also see Bug# 622680

Comment 2 jiri vanek 2010-11-03 14:56:11 UTC

*** This bug has been marked as a duplicate of bug 643674 ***


Note You need to log in before you can comment on or make changes to this bug.