Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 597096 - [UMing] Only upper half characters are displayed.in java application
Summary: [UMing] Only upper half characters are displayed.in java application
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: cjkuni-fonts
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peng Wu
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 603348
TreeView+ depends on / blocked
 
Reported: 2010-05-28 06:05 UTC by Ding-Yi Chen
Modified: 2011-05-30 05:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 603348 (view as bug list)
Environment:
Last Closed: 2011-05-30 05:39:58 UTC


Attachments (Terms of Use)
Freemind with UMing font (deleted)
2010-05-28 06:05 UTC, Ding-Yi Chen
no flags Details
Freemind with UKai font (deleted)
2010-05-28 06:07 UTC, Ding-Yi Chen
no flags Details
Fontconfig file for java (deleted)
2010-05-28 06:08 UTC, Ding-Yi Chen
no flags Details

Description Ding-Yi Chen 2010-05-28 06:05:43 UTC
Created attachment 417485 [details]
Freemind with UMing font

Description of problem:
When using uming font in java application, only upper half the characters are displayed.

Version-Release number of selected component (if applicable):
cjkuni-uming-fonts-0.2.20080216.1-37.fc13.noarch

How reproducible:
Always

Steps to Reproduce:
1. We use freemind for example.
2. Download freemind zip and install it, say, in /tmp/freemind
3. cd /tmp/freemind; chmod 755 freemind.sh; ./freemind.sh
4. In F-13, java is not able to show Chinese, because the font name and path changes. Suppose we use java-1.6.0-openjdk.
5. su or sudo as root
6. cd /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib
7. cp fontconfig.Fedora.properties.src fontconfig.Fedora.properties
8. Either manually search/replace AR PL ShanHeiSong to AR PL UMing HK fontconfig.Fedora.properties; or use attached fontconfig.Fedora.properties
9. Start freemind to see the how font is displayed
  
Actual results:
UMing characters are cut in to half. See Screenshot-uming.png

Expected results:
UMing characters are displayed as whole.

Additional info:
UKai seems act normally. See Screenshot-ukai.png

Comment 1 Ding-Yi Chen 2010-05-28 06:07:16 UTC
Created attachment 417487 [details]
Freemind with UKai font

Comment 2 Ding-Yi Chen 2010-05-28 06:08:29 UTC
Created attachment 417488 [details]
Fontconfig file for java

Comment 3 Nicolas Mailhot 2010-06-12 14:26:03 UTC
Uming like many other CJK fonts is difficult to handle by apps. While it is possible that uming could be simplified, your problem is almost certainly due to bad font handling code in java, that was only tested on simple latin fonts, and not on a complex one like uming.

I've opened an openjdk bug, leaving this one alone if someone wants to try to convert uming to use more common font conventions.

Comment 4 Fedora Admin XMLRPC Client 2010-07-15 00:31:17 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 5 Peng Wu 2011-05-30 05:39:58 UTC
I checked this bug on Fedora 14, it is fixed.
Move this bug to F-14, and close this bug.


Note You need to log in before you can comment on or make changes to this bug.