Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 597063 - Xorg crash with compositing
Summary: Xorg crash with compositing
Keywords:
Status: CLOSED DUPLICATE of bug 584832
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 13
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-28 03:28 UTC by Bill Newton
Modified: 2018-04-11 06:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-28 09:14:50 UTC


Attachments (Terms of Use)
Backtrack from xorg log. (deleted)
2010-05-28 03:28 UTC, Bill Newton
no flags Details
Full Xorg log (deleted)
2010-05-28 03:30 UTC, Bill Newton
no flags Details

Description Bill Newton 2010-05-28 03:28:36 UTC
Created attachment 417452 [details]
Backtrack from xorg log.

Description of problem:

Xorg reproducibly crashes often when opengl based compositing is turned on. Many different ways to trigger.

Version-Release number of selected component (if applicable):
1.8.0-12.fc13

How reproducible:
Very. Every time. 
With Compositing on, try to navigate to a website in konqueror. Result => crash. Many other things result in the same crash.

Steps to Reproduce:
1.Turn Composting on (crashes with kde or gnome) 
2. Start Konqueror
3. Navigate to site
  
Actual results:
Crash

Expected results:
Not crash

Additional info:
Backtrack from xorg log included

Comment 1 Bill Newton 2010-05-28 03:30:33 UTC
Created attachment 417453 [details]
Full Xorg log

In case more of the info from the log file is necessary.

Comment 2 Matěj Cepl 2010-05-28 08:51:38 UTC
acktrace:
[   113.965] 0: /usr/bin/Xorg (xorg_backtrace+0x28) [0x49e708]
[   113.965] 1: /usr/bin/Xorg (0x400000+0x603d9) [0x4603d9]
[   113.965] 2: /lib64/libc.so.6 (0x31ed800000+0x32a40) [0x31ed832a40]
[   113.965] 3: /usr/bin/Xorg (dixLookupPrivate+0xa) [0x445caa]
[   113.965] 4: /usr/lib64/xorg/modules/extensions/libglx.so (0x7fac52e61000+0x3e99b) [0x7fac52e9f99b]
[   113.965] 5: /usr/lib64/xorg/modules/extensions/libglx.so (0x7fac52e61000+0x35e6f) [0x7fac52e96e6f]
[   113.965] 6: /usr/bin/Xorg (FreeResource+0x140) [0x449570]
[   113.965] 7: /usr/lib64/xorg/modules/extensions/libglx.so (0x7fac52e61000+0x32f19) [0x7fac52e93f19]
[   113.965] 8: /usr/lib64/xorg/modules/extensions/libglx.so (0x7fac52e61000+0x35c80) [0x7fac52e96c80]
[   113.965] 9: /usr/bin/Xorg (0x400000+0x2c32c) [0x42c32c]
[   113.965] 10: /usr/bin/Xorg (0x400000+0x219ca) [0x4219ca]
[   113.965] 11: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x31ed81ec5d]
[   113.965] 12: /usr/bin/Xorg (0x400000+0x21579) [0x421579]
[   113.965] Segmentation fault at address 0x290
[   113.965]
Fatal server error:
[   113.965] Caught signal 11 (Segmentation fault). Server aborting
[   113.965]
[   113.965]
Please consult the Fedora Project support
         at http://bodhi.fedoraproject.org/
 for help.

Comment 3 Matěj Cepl 2010-05-28 09:14:50 UTC
I will risk it and declare this a duplicate of bug 558724. Feel free to reopen, if you disagree.

Thank you for reporting the bug.

*** This bug has been marked as a duplicate of bug 558724 ***

Comment 4 Bill Newton 2010-05-28 14:32:42 UTC
I'm no Xorg Expert, but this happened after upgrading to F13. F12 did not exhibit this behaviour, the "duplicate" bug has an earlier version Xorg and related packages. Plus, the submitter said that using the (now Fedroa 13) Rawhide packages fixed the issue. https://bugzilla.redhat.com/show_bug.cgi?id=558724#c1

Comment 5 Bill Newton 2010-06-04 05:15:57 UTC
Changing the potential duplicate. 

https://bugzilla.redhat.com/show_bug.cgi?id=584832 sounds like a much closer match. 

In light of that it should probably stay closed duplicate.

*** This bug has been marked as a duplicate of bug 584832 ***

Comment 6 Bill Newton 2010-06-13 03:28:48 UTC
Again, not 100% sure of the cause but it seems to be fixed now.

What's been upgraded?  Oh, a lot of things. I upgraded to 4.4.85 (KDE 4.4.85 (KDE 4.5 Beta2)) and it doesn't crash anymore. That's the only thing I think I've upgraded relevant to this issue. There are some display issues with screen tearing and non support of various compositing features that used to work, but at least it doesn't crash.


Note You need to log in before you can comment on or make changes to this bug.