Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 597024 - HP "JetDirect" requires libcrypto
Summary: HP "JetDirect" requires libcrypto
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-27 23:35 UTC by Juan Manuel Rodriguez
Modified: 2010-06-17 12:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-17 12:04:45 UTC


Attachments (Terms of Use)

Description Juan Manuel Rodriguez 2010-05-27 23:35:30 UTC
Description of problem:
After several hours attempting to set up a network printer, I decided to recompile the hplip driver from upstream. 

Upon following instructions, I found this:
http://hplipopensource.com/hplip-web/images/install_7.png

I noticed I didn't have libcrypto, installed it, and it all magically worked. Now I want my 2 hours back :-/


Version-Release number of selected component (if applicable):
hplip-3.10.2-11.fc13.i686


How reproducible:
Very. 

Steps to Reproduce:
1. Remove libssh (Which provides libcrypto)
2. Attempt to set up a jetdirect printer (Try the hp-gui, for instance)
3. Fail
4. Install libssh
5. Scan and Print wirelessly
 
I think adding "Requires: libssh" should be enough. Failing that, splitting libcrypto out of libssh, and adding libcrypto as a requires could be an option.

I'm not sure if I'm filing the bug on the correct component, but its definitely an issue with "JetDirect" printers.

Comment 1 Tim Waugh 2010-05-28 08:54:29 UTC
The hplip package already requires libcrypto.

[tim@localhost ~]$ rpm -q --requires hplip | grep crypto
libcrypto.so.10()(64bit)  
[tim@localhost ~]$ rpm -q --whatprovides 'libcrypto.so.10()(64bit)'
openssl-1.0.0-1.fc13.x86_64
[tim@localhost ~]$ rpm --test -e openssl 2>&1 | grep hplip
	libcrypto.so.10()(64bit) is needed by (installed) hplip-libs-3.10.2-11.fc13.x86_64
	libcrypto.so.10()(64bit) is needed by (installed) hplip-3.10.2-11.fc13.x86_64

And libssh doesn't provide libcrypto:

[tim@localhost ~]$ repoquery -ql libssh | grep '\.so\.'
/usr/lib/libssh.so.4
/usr/lib/libssh.so.4.1.0
/usr/lib64/libssh.so.4
/usr/lib64/libssh.so.4.1.0

And libssh is not referenced in the source code of hplip anywhere.

So can you please expand in more detail on exactly how you're printing and how it fails please?  Also, please try removing libssh and verifying that it breaks things again.

Comment 2 Juan Manuel Rodriguez 2010-05-28 20:26:00 UTC
Hmm, you're right about that. 

I removed libssh and could still print. It was a weird coincidence, I guess?

I was running the hp gui manager, and as soon as I installed libssh, the printers showed up. (I had copypasted my printer.conf from another F-13 laptop). 

Due to lack of stacktrace or anything usable, I guess you should mark this bug as bogus? 

Leave it up a few more days though, I'll try replicating using a virtual machine.

I'll try to pay *more* attention on what I'm doing to replicate. 

Thanks

Comment 3 Tim Waugh 2010-06-17 12:04:45 UTC
Closing; please re-open if you take another look at this and find how to reproduce it.


Note You need to log in before you can comment on or make changes to this bug.