Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 597021 - udev rules still use SYSFS{}
Summary: udev rules still use SYSFS{}
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: piklab
Version: 13
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Alain Portal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 598417 636772 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-27 23:30 UTC by Jérôme Benoit
Modified: 2011-04-29 03:03 UTC (History)
8 users (show)

Fixed In Version: piklab-0.15.10-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-07 19:56:13 UTC


Attachments (Terms of Use)
Updated rules for piklab (deleted)
2010-07-11 15:56 UTC, David Dillow
no flags Details

Description Jérôme Benoit 2010-05-27 23:30:12 UTC
Description of problem:

udev rules still use SYSFS{}

Version-Release number of selected component (if applicable):

piklab-0.15.3-5.fc13.x86_64

How reproducible:

Well, booting with piklab installed

Steps to Reproduce:
1.
2.
3.
  
Actual results:

udevd[516]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /etc/udev/rules.d/026-microchip.rules:2

udevd[516]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /etc/udev/rules.d/026-microchip.rules:4

udevd[516]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /etc/udev/rules.d/026-microchip.rules:6

udevd[516]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /etc/udev/rules.d/026-microchip.rules:8


Expected results:

No warning. 

Additional info:

Comment 1 David Dillow 2010-07-11 15:56:06 UTC
Created attachment 431008 [details]
Updated rules for piklab

This is an untested version of the udev rules for piklab. I don't have the hardware to test with, but it looks like a straight-forward conversion.

Comment 2 Alain Portal 2010-09-24 07:14:06 UTC
*** Bug 636772 has been marked as a duplicate of this bug. ***

Comment 3 Chitlesh GOORAH 2010-10-05 19:06:40 UTC
*** Bug 598417 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2011-01-29 18:33:54 UTC
piklab-0.15.10-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/piklab-0.15.10-1.fc14

Comment 5 Fedora Update System 2011-01-29 18:34:01 UTC
piklab-0.15.10-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/piklab-0.15.10-1.fc13

Comment 6 Fedora Update System 2011-01-29 18:34:07 UTC
piklab-0.15.10-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/piklab-0.15.10-1.el6

Comment 7 Fedora Update System 2011-01-30 17:26:14 UTC
piklab-0.15.10-1.el6 has been pushed to the Fedora EPEL 6 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update piklab'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/piklab-0.15.10-1.el6

Comment 8 Fedora Update System 2011-02-07 19:56:07 UTC
piklab-0.15.10-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-02-07 19:58:16 UTC
piklab-0.15.10-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-02-17 20:49:32 UTC
piklab-0.15.10-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Steve Chapel 2011-04-29 03:03:41 UTC
When I upgraded Fedora 13 to Fedora 14 today, I received this warning:

Warning in file "/usr/share/applications/gnome-nautilus-folder-handler.desktop": usage of MIME type "x-directory/gnome-default-handler" is discouraged ("x-directory" is an old media type that should be replaced with a modern equivalent)

This is the warning described in duplicate bug 598417.

After the upgrade, the file /usr/share/applications/gnome-nautilus-folder-handler.desktop contains the line:

MimeType=x-directory/gnome-default-handler;x-directory/normal;inode/directory;application/x-gnome-saved-search;


Note You need to log in before you can comment on or make changes to this bug.