Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 597009 - [abrt] crash in pychess-0.10-0.4.20100504hg.fc13: engineNest.py:403:getEngineN:IndexError: list index out of range
Summary: [abrt] crash in pychess-0.10-0.4.20100504hg.fc13: engineNest.py:403:getEngine...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pychess
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Thomas Spura
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:8d5a6658
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-27 22:33 UTC by David Webb
Modified: 2010-05-28 13:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-28 13:21:01 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-27 22:33 UTC, David Webb
no flags Details

Description David Webb 2010-05-27 22:33:38 UTC
abrt 1.1.0 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/pychess
component: pychess
executable: /usr/bin/pychess
kernel: 2.6.33.4-95.fc13.x86_64
package: pychess-0.10-0.4.20100504hg.fc13
reason: engineNest.py:403:getEngineN:IndexError: list index out of range
release: Fedora release 13 (Goddard)

backtrace
-----
engineNest.py:403:getEngineN:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pychess/widgets/TaskerManager.py", line 202, in startClicked
    engine = discoverer.getEngineN (opponent-1)
  File "/usr/lib/python2.6/site-packages/pychess/Players/engineNest.py", line 403, in getEngineN
    return self.getEngines()[self.getEngines().keys()[index]]
IndexError: list index out of range

Local variables in innermost frame:
index: 3
self: <EngineDiscoverer object at 0x207a500 (pychess+Players+engineNest+EngineDiscoverer at 0x1868200)>

How to reproduce
-----
1. install pyChess and GNUChess
2. set difficulty in pyChess to "1" with an opponent as GNUChess
3. Start Game.

Comment 1 David Webb 2010-05-27 22:33:40 UTC
Created attachment 417410 [details]
File: backtrace

Comment 2 Michel Alexandre Salim 2010-05-28 05:45:58 UTC
Odd, the exact steps on a fresh installation of pychess works just fine. Could you try this?

$ mv ~/.config/pychess{,.backup}
$ pychess

and attempt to reproduce? you can do "rm -r ~/.config/pychess && mv ~/.config/pychess{.backup,}" to get your old configuration back.

Also, what are the list of opponents available to pick from?

Comment 3 David Webb 2010-05-28 06:03:47 UTC
(In reply to comment #2)
> Odd, the exact steps on a fresh installation of pychess works just fine. Could
> you try this?
> 
> $ mv ~/.config/pychess{,.backup}
> $ pychess
> 
> and attempt to reproduce? you can do "rm -r ~/.config/pychess && mv
> ~/.config/pychess{.backup,}" to get your old configuration back.
> 
> Also, what are the list of opponents available to pick from?    

ok, I've since played chess fine...
must have been a temp but because I didn't reboot or anything before trying to play after install

but each opponent appeared twice on the list...
now it's fine again.

I don't know whether this is a temp bug, but it certainly doesn't hinder me anymore, so I'm not fussed.

Comment 4 David Webb 2010-05-28 06:06:21 UTC
Could not reproduce.

Comment 5 Michel Alexandre Salim 2010-05-28 13:21:01 UTC
Probably something that happens only the first time you upgrade, then. The pychess homepage does mention that they recently moved the config file to ~/.config/pychess -- perhaps there's a problem the first time that happens.


Note You need to log in before you can comment on or make changes to this bug.