Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 597008 - AttributeError: 'NoneType' object has no attribute 'format'
Summary: AttributeError: 'NoneType' object has no attribute 'format'
Keywords:
Status: CLOSED DUPLICATE of bug 573492
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 13
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:65764756be7d7eb25...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-27 22:30 UTC by Chris Miller
Modified: 2010-05-28 03:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-28 03:25:34 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (deleted)
2010-05-27 22:30 UTC, Chris Miller
no flags Details
Attached traceback automatically from anaconda. (deleted)
2010-05-27 22:35 UTC, Chris Miller
no flags Details
Attached traceback automatically from anaconda. (deleted)
2010-05-27 22:37 UTC, Chris Miller
no flags Details

Description Chris Miller 2010-05-27 22:30:42 UTC
The following was filed automatically by anaconda:
anaconda 13.42 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/yuminstall.py", line 839, in mirrorFailureCB
    dev.format.mountpoint = self.tree
  File "/usr/lib/python2.6/site-packages/urlgrabber/mirror.py", line 297, in _failure
    action = cb(cb_obj, *args, **kwargs) or {}
  File "/usr/lib/python2.6/site-packages/urlgrabber/mirror.py", line 402, in _mirror_try
    self._failure(gr, obj)
  File "/usr/lib/python2.6/site-packages/urlgrabber/mirror.py", line 408, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 810, in _getFile
    size=size
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1569, in _retrieveMD
    size=thisdata.size)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1604, in getGroups
    return self._retrieveMD('group_gz', retrieve_can_fail=True)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 708, in _getGroups
    groupfile = repo.getGroups()
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 797, in <lambda>
    comps = property(fget=lambda self: self._getGroups(),
  File "/usr/lib/anaconda/yuminstall.py", line 1187, in doGroupSetup
    sel = filter(lambda g: g.selected, self.ayum.comps.get_groups())
  File "/usr/lib/anaconda/yuminstall.py", line 1178, in doBackendSetup
    self.doGroupSetup(anaconda)
  File "/usr/lib/anaconda/backend.py", line 282, in doBackendSetup
    if anaconda.backend.doBackendSetup(anaconda) == DISPATCH_BACK:
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1313, in nextClicked
    self.anaconda.dispatch.gotoNext()
AttributeError: 'NoneType' object has no attribute 'format'

Comment 1 Chris Miller 2010-05-27 22:30:46 UTC
Created attachment 417409 [details]
Attached traceback automatically from anaconda.

Comment 2 Chris Miller 2010-05-27 22:35:18 UTC
Created attachment 417411 [details]
Attached traceback automatically from anaconda.

Comment 3 Chris Miller 2010-05-27 22:37:37 UTC
Created attachment 417412 [details]
Attached traceback automatically from anaconda.

Comment 4 Chris Lumens 2010-05-28 03:25:34 UTC

*** This bug has been marked as a duplicate of bug 573492 ***


Note You need to log in before you can comment on or make changes to this bug.