Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 596916 - [abrt] crash in evolution-2.30.1-5.fc13: malloc_consolidate: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV) ( Or you had your buddy list contact sync activated )
Summary: [abrt] crash in evolution-2.30.1-5.fc13: malloc_consolidate: Process /usr/bin...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3fbf84f1bd5025fd39a3798d05d...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-27 18:49 UTC by Rene Jr Purcell
Modified: 2010-11-08 07:49 UTC (History)
3 users (show)

Fixed In Version: evolution-2.32.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-08 07:49:12 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-27 18:50 UTC, Rene Jr Purcell
no flags Details
Another dump of a crash (deleted)
2010-05-27 18:53 UTC, Rene Jr Purcell
no flags Details
Log of Evolution crash with the sync buddy list option enabled (deleted)
2010-05-27 21:04 UTC, Rene Jr Purcell
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 626579 None None None Never

Description Rene Jr Purcell 2010-05-27 18:49:59 UTC
abrt 1.1.0 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: evolution
comment: Evolution seems to work fine on another computer. On this computer I had restored a "backup" from my Evolution which I did on my last Fedora 12 install... Maybe the problem come from this particular backup or backup in general.
component: evolution
crash_function: malloc_consolidate
executable: /usr/bin/evolution
global_uuid: 3fbf84f1bd5025fd39a3798d05d158f1af9bb5e1
kernel: 2.6.33.3-85.fc13.i686.PAE
package: evolution-2.30.1-5.fc13
rating: 4
reason: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. After a fresh F13 install, start evolution and at the first start wizard, select a backup you did "mine was from my old Fedora12 install"
2. wait... at the begining I was able to work, no crash. After few hours of use, crash every 2 minutes. Even if I don't use it..

Comment 1 Rene Jr Purcell 2010-05-27 18:50:01 UTC
Created attachment 417344 [details]
File: backtrace

Comment 2 Rene Jr Purcell 2010-05-27 18:53:56 UTC
Created attachment 417346 [details]
Another dump of a crash

Another dump of a crash

Comment 3 Rene Jr Purcell 2010-05-27 21:01:23 UTC
I was unable to work becasue Evolution crashed every minutes... So I started to debug and try to find what's the problem. I think I've found it...

I started Evolution in a shell and then I was able to see more information on the crash.

[rpurcell@t61ig ~]$ evolution
(evolution:15208): e-data-server-DEBUG: Loading categories from "/home/rpurcell/.evolution/categories.xml"
(evolution:15208): e-data-server-DEBUG: Loaded 31 categories


bbdb: Buddy list has changed since last sync.
bbdb: Synchronizing buddy list to contacts...
bbdb: Done syncing buddy list to contacts.
*** glibc detected *** evolution: corrupted double-linked list: 0x09c873a0 ***
======= Backtrace: =========



Yes I had the option to sync the buddy list contacts enabled. Once I removed this my Evolution is stable as ROCK. So it really seems like a bug.. I can provide more information if you want. Just ask.

I'll attach the full log.

@+

Comment 4 Rene Jr Purcell 2010-05-27 21:04:31 UTC
Created attachment 417382 [details]
Log of Evolution crash with the sync buddy list option enabled

I don't know if other backtrace will still be helpfull but this is the backtrace that give me the information about the buddy list sync problem.

Comment 5 Milan Crha 2010-11-08 07:49:12 UTC
Thanks for a bug report. This particular one had been fixed upstream [1] about two months ago and the fix is included in evolution 2.32.0.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=626579


Note You need to log in before you can comment on or make changes to this bug.