Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 596889 - [RHEL6] fail while loading module can lead to invalid memory access
Summary: [RHEL6] fail while loading module can lead to invalid memory access
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks: 846704
TreeView+ depends on / blocked
 
Reported: 2010-05-27 17:53 UTC by Aristeu Rozanski
Modified: 2013-03-18 15:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-18 15:24:36 UTC
Target Upstream Version:


Attachments (Terms of Use)
console log (deleted)
2010-05-27 17:55 UTC, Aristeu Rozanski
no flags Details

Description Aristeu Rozanski 2010-05-27 17:53:53 UTC
Description of problem:
While running a test of a pre-2.6.32-31.el6 kernel:

Starting monitoring for VG vg_inteld3ca201: Starting monitoring for VG vg_inteld3ca201:   3 logical volume(s) in volume group "vg_inteld3ca201" monitored
[  OK  ]
  3 logical volume(s) in volume group "vg_inteld3ca201" monitored
[  OK  ]
FATAL: Error inserting ipv6 (/lib/modules/2.6.32-31.el6.i686.debug/kernel/net/ipv6/ipv6.ko): Cannot allocate memory
FATAL: Error inserting ipv6 (/lib/modules/2.6.32-31.el6.i686.debug/kernel/net/ipv6/ipv6.ko): Cannot allocate memory
Bringing up loopback interface:  Bringing up loopback interface:  [  OK  ]
[  OK  ]
Bringing up interface eth0:  Bringing up interface eth0:  
Determining IP information for eth0...
Determining IP information for eth0... done.
 done.
[  OK  ]
[  OK  ]
BUG: unable to handle kernel paging request at ff107b18
IP: [<c0605319>] list_del+0x9/0x90
*pdpt = 0000000000c5f001 *pde = 000000002fdd3067 *pte = 0000000000000000 
Oops: 0000 [#1] SMP 
last sysfs file: /sys/devices/pci0000:00/0000:00:19.0/net/eth0/ifindex
Modules linked in: ipv6(+)(U) dm_mirror(U) dm_region_hash(U) dm_log(U) snd_hda_codec_realtek(U) snd_hda_intel(U) snd_hda_codec(U) snd_hwdep(U) snd_seq(U) snd_seq_device(U) snd_pcm(U) snd_timer(U) snd(U) iTCO_wdt(U) soundcore(U) i2c_i801(U) snd_page_alloc(U) iTCO_vendor_support(U) i7core_edac(U) e1000e(U) edac_core(U) wmi(U) sg(U) serio_raw(U) ext4(U) mbcache(U) jbd2(U) sd_mod(U) sr_mod(U) crc_t10dif(U) cdrom(U) ata_generic(U) pata_acpi(U) firewire_ohci(U) firewire_core(U) crc_itu_t(U) ahci(U) pata_marvell(U) nouveau(U) ttm(U) drm_kms_helper(U) drm(U) i2c_algo_bit(U) i2c_core(U) dm_mod(U) [last unloaded: microcode]

Pid: 1484, comm: modprobe Not tainted (2.6.32-31.el6.i686.debug #1)         
EIP: 0060:[<c0605319>] EFLAGS: 00010296 CPU: 10
EIP is at list_del+0x9/0x90
EAX: fac318e8 EBX: fac318e8 ECX: 00000000 EDX: ff107b18
ESI: fac318e8 EDI: 00000000 EBP: f3471f30 ESP: f3471f18
 DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
Process modprobe (pid: 1484, ti=f3470000 task=f37d0a20 task.ti=f3470000)
Stack:
 22222222 22222222 00000000 c0a72b40 00000000 f3471f40 f3471f40 c078b5ac
<0> fac318e8 fac341c0 f3471f4c c078b6f9 fffffff4 f3471f5c f7e6d24b f3471f78
<0> fffffffc f3471f88 c040303d fac341c0 c0a3d7e4 fffffffc fac341c0 00000000
Call Trace:
 [<c078b5ac>] ? unregister_pernet_operations+0xc/0x50
 [<c078b6f9>] ? unregister_pernet_subsys+0x19/0x30
 [<f7e6d24b>] ? inet6_init+0x24b/0x296 [ipv6]
 [<c040303d>] ? do_one_initcall+0x2d/0x1d0
 [<f7e6d000>] ? inet6_init+0x0/0x296 [ipv6]
[-- MARK -- Wed May 26 19:30:00 2010]
[-- MARK -- Wed May 26 19:35:00 2010]

by a quick look, it looked like upstream commit
218ce7351413b8287a80fab1d7b94906a5559f01 could be related, but it's already
on RHEL6 kernel tree.

Version-Release number of selected component (if applicable):
2.6.32-31.el6, i386 machine.

How reproducible:
Unknown. First and only machine to present this problem.

Comment 1 Aristeu Rozanski 2010-05-27 17:55:03 UTC
Created attachment 417326 [details]
console log

Comment 2 Aristeu Rozanski 2010-05-27 17:58:03 UTC
Box: intel-d3ca2-01.lab.bos.redhat.com

Comment 4 RHEL Product and Program Management 2010-06-07 16:05:55 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 5 RHEL Product and Program Management 2010-07-15 14:37:40 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 6 RHEL Product and Program Management 2011-10-07 15:04:58 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 7 Jes Sorensen 2013-03-18 15:24:36 UTC
Per discussion with Aris this seems to have gotten fixed along the way

Closing


Note You need to log in before you can comment on or make changes to this bug.