Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 596852 - F-13 nvr < F-12 nvr
Summary: F-13 nvr < F-12 nvr
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: preupgrade
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-27 16:15 UTC by Jonathan Underwood
Modified: 2010-09-22 16:00 UTC (History)
5 users (show)

Fixed In Version: preupgrade-1.1.8-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-22 16:00:39 UTC


Attachments (Terms of Use)

Description Jonathan Underwood 2010-05-27 16:15:08 UTC
Description of problem:
Using preupgrade on a fully updated version of F-12 to F-13 and then running
package-cleanup --orphans lists preupgrade as being orphaned. The reason is
that the F12 version has a greater nvr than the F13 version - see below. Please
push updated packages for F13.

# yum downgrade preupgrade
Loaded plugins: presto, refresh-packagekit
Setting up Downgrade Process
Resolving Dependencies
--> Running transaction check
---> Package preupgrade.noarch 0:1.1.4-1.fc13 set to be updated
---> Package preupgrade.noarch 0:1.1.7-1.fc12 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package            Arch           Version                 Repository      Size
================================================================================
Downgrading:
 preupgrade         noarch         1.1.4-1.fc13            fedora          87 k

Transaction Summary
================================================================================
Remove        0 Package(s)
Reinstall     0 Package(s)
Downgrade     1 Package(s)

Total download size: 87 k
Is this ok [y/N]: 



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 David Kovalsky 2010-08-09 12:28:31 UTC
ping - any updates about the F12 NVR > F13 NVR? 

It's a simple fix :)

Comment 2 Nicola Soranzo 2010-09-22 16:00:39 UTC
It has been incidentally fixed with preupgrade-1.1.8-1.fc13 .


Note You need to log in before you can comment on or make changes to this bug.