Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 596796 - regression for 'suspend to ram/resume' on laptop asus f3sc
Summary: regression for 'suspend to ram/resume' on laptop asus f3sc
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 13
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2010-05-27 14:19 UTC by kakashizilla
Modified: 2011-06-02 15:00 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2011-06-02 15:00:08 UTC

Attachments (Terms of Use)
log file (deleted)
2010-05-27 14:19 UTC, kakashizilla
no flags Details

Description kakashizilla 2010-05-27 14:19:01 UTC
Created attachment 417262 [details]
log file

Description of problem:
I have just upgrade from Fedora 11, and found a big regression, trying 
to suspend to ram my laptop (asus f3sc).
Where everything was fine on fedora 11, the laptop freeze on resume in fedora 13.
It goes to sleep fine as the log shows, but freeze at resume, even in init 3.
This is a big problem when you work with laptops.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:
A perfect suspend to ram/resume function

Additional info:

Comment 1 kakashizilla 2010-05-29 09:48:53 UTC
Hummmm... I am not sure this is a kernel bug.
I have installed FC12 : suspend to ram/resume worked fine just after the installation.
After the update of the system, the resume failed as in FC13, even if I boot on the initial kernel (

I do not know which update breaks this function.
Does someone have an idea ?

Comment 2 kakashizilla 2010-06-02 07:46:16 UTC
OK, I have found where is the problem.
I have followed this documentation :
The problem happens at the [devices] stage, so I tried to suspend after unloading some modules.
And the guilty module is : 'atl1'
Suspend to ram/resume works fine after unloading it ! So the workaround is very easy.
It is tested on an up to date FC12. I have not yet reinstalled FC13, but I guess it is the same.

Comment 3 kakashizilla 2010-06-03 12:20:31 UTC
It is the same on FC13, and the workaround is valid.
The card is : 
Ethernet controller: Atheros Communications L1 Gigabit Ethernet (rev b0)

Comment 4 Bug Zapper 2011-06-02 13:14:50 UTC
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here:

Comment 5 kakashizilla 2011-06-02 15:00:08 UTC
Fixed in newer kernel: patch

Note You need to log in before you can comment on or make changes to this bug.