Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 596791 - corrupted double-linked list at the end of boot
Summary: corrupted double-linked list at the end of boot
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: plymouth
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
: 589644 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-27 14:10 UTC by Jiri Denemark
Modified: 2010-11-10 21:20 UTC (History)
3 users (show)

Fixed In Version: plymouth-0.8.3-11.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-10 21:20:50 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jiri Denemark 2010-05-27 14:10:58 UTC
Description of problem:

When switched to details theme, plymouthd fails at the end of boot just before gdm should appear. The message printed is:

*** glibc detected *** /bin/plymouthd: corrupted double-linked list: 0x0000000001390500

Version-Release number of selected component (if applicable):

kernel-2.6.32-29.el6.x86_64
plymouth-0.8.3-3.el6.x86_64


How reproducible:

sometimes, ~80%

Steps to Reproduce:
1. plymouth-set-default-theme details
2. recreate mkinitrd
3. reboot
  
Actual results:


Expected results:


Additional info:

Comment 1 RHEL Product and Program Management 2010-05-27 14:16:05 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Ray Strode [halfline] 2010-07-01 02:03:11 UTC
Fix for this is here:

http://cgit.freedesktop.org/plymouth/commit/?id=0e232e29765cade22b9e8cba3b0c372eb4db58f9

devack+

Comment 3 Ray Strode [halfline] 2010-07-01 21:26:42 UTC
*** Bug 589644 has been marked as a duplicate of this bug. ***

Comment 4 Lubos Kocman 2010-07-13 08:14:50 UTC
Verified

I was facing to this issue few times as well.

I tried to reproduce this issue on plymouth-0.8.3-11.el6.{x86_64,i686} as is described in Comment 2. But seems like issue is fixed correctly.

Please feel free to reopen issue if you'll face the problem again.

Comment 5 Lubos Kocman 2010-07-13 08:15:23 UTC
Hello

Sorry I ment Comment 1

Comment 6 releng-rhel@redhat.com 2010-11-10 21:20:50 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.