Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 596744 - SELinux is preventing gcm-apply "write" access on /var/run/cups/cups.sock.
Summary: SELinux is preventing gcm-apply "write" access on /var/run/cups/cups.sock.
Keywords:
Status: CLOSED DUPLICATE of bug 588295
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 13
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:cc5b35163bb...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-27 12:32 UTC by Anderson Freitas
Modified: 2010-08-05 16:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-27 14:03:11 UTC


Attachments (Terms of Use)

Description Anderson Freitas 2010-05-27 12:32:19 UTC
Summary:

SELinux is preventing gcm-apply "write" access on /var/run/cups/cups.sock.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by gcm-apply. It is not expected that this
access is required by gcm-apply and this access may signal an intrusion attempt.
It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:cupsd_var_run_t:s0
Target Objects                /var/run/cups/cups.sock [ sock_file ]
Source                        gcm-apply
Source Path                   /usr/bin/gcm-apply
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-15.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.4-95.fc13.i686.PAE #1
                              SMP Thu May 13 05:38:26 UTC 2010 i686 i686
Alert Count                   11
First Seen                    Wed 26 May 2010 10:57:32 PM BRT
Last Seen                     Thu 27 May 2010 12:09:05 AM BRT
Local ID                      caa9dbc7-b935-4ba5-a8f3-c28bce0af080
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1274929745.511:16): avc:  denied  { write } for  pid=1733 comm="gcm-apply" name="cups.sock" dev=sda4 ino=2884151 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:cupsd_var_run_t:s0 tclass=sock_file



Hash String generated from  catchall,gcm-apply,xdm_t,cupsd_var_run_t,sock_file,write
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t cupsd_var_run_t:sock_file write;

Comment 1 Daniel Walsh 2010-05-27 14:03:11 UTC

*** This bug has been marked as a duplicate of bug 588295 ***


Note You need to log in before you can comment on or make changes to this bug.