Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 596726 - Error finding block device of /dev/loop-f13-live.dev. Aborting!
Summary: Error finding block device of /dev/loop-f13-live.dev. Aborting!
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Huff
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-27 11:55 UTC by Jan Kratochvil
Modified: 2010-08-03 16:21 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-03 16:21:05 UTC


Attachments (Terms of Use)

Description Jan Kratochvil 2010-05-27 11:55:52 UTC
Description of problem:
There is a condition no longer compatible with F13 bash aborting the operation.

Version-Release number of selected component (if applicable):
livecd-tools-031-1.fc12.1.x86_64
bash-4.1.2-4.fc13.x86_64

How reproducible:
Always.

Steps to Reproduce:
Try to build biarch USB flash using:
http://lists.fedoraproject.org/pipermail/livecd/2010-March/005755.html

Actual results:
Error finding block device of /dev/loop-f13-live.dev.  Aborting!

Expected results:
built image

Additional info:
The condition
    if [[ "$DEV" =~ "/dev/loop*" ]]; then
was already wrong before as the right side is a regex, not a shell wildcard pattern.  Due to the bash change described in Bug 558537 (not a bug) this pattern no longer works with F13 bash.  IMO the correct one is:
    if [[ $DEV =~ ^/dev/loop ]]; then

It still does not work, though:
mount: you must specify the filesystem type
But this will be some different problem for a different Bug.

Comment 1 Jan Kratochvil 2010-08-03 16:21:05 UTC
Fixed by:
http://lists.fedoraproject.org/pipermail/livecd/2010-August/006055.html

Should I continue filing the fixes here when they are being ignored?


Note You need to log in before you can comment on or make changes to this bug.