Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 596724 - KickstartValueError: The following problem occurred on line 39 of the kickstart file.
Summary: KickstartValueError: The following problem occurred on line 39 of the kicksta...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: cobbler
Version: 15
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Bill Peck
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-27 11:48 UTC by Igor Zhang
Modified: 2012-09-13 14:56 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-27 13:35:12 UTC


Attachments (Terms of Use)
kickstart (deleted)
2010-05-27 11:48 UTC, Igor Zhang
no flags Details

Description Igor Zhang 2010-05-27 11:48:36 UTC
Created attachment 417207 [details]
kickstart

Description of problem:
With RHEL6.0-20100524.n.0_nfs-Server-x86_64, I got this:
...
Looking for installation images on CD device /dev/sr0Running anaconda 13.21.45,
the Red Hat Enterprise Linux system installer - please wait.
Finding storage devices
anaconda 13.21.45 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/kickstart.py", line 713, in execute
    raise KickstartValueError, formatErrorMsg(self.lineno, msg="Partition
requires a size specification")
  File "/usr/lib/anaconda/kickstart.py", line 1134, in execute
    obj.execute(self.anaconda)
  File "/usr/bin/anaconda", line 1094, in <module>
    ksdata.execute()
KickstartValueError: The following problem occurred on line 39 of the kickstart
file:

Partition requires a size specification


install exited abnormally [1/1] 
The system will be rebooted when you press Ctrl-C or Ctrl-Alt-Delete.


Version-Release number of selected component (if applicable):


How reproducible:
Just install above distro on machine intel-s3e3144-03.rhts.eng.nay.redhat.com. Or perhaps on similar machines below:
    intel-s3e3144-01.rhts.eng.nay.redhat.com  	 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI
intel-s3e3144-02.rhts.eng.nay.redhat.com 	53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI
intel-s3e3144-03.rhts.eng.nay.redhat.com 	53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI
intel-s3e3144-04.rhts.eng.nay.redhat.com 	53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI
intel-s3e3144-05.rhts.eng.nay.redhat.com 	53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI 

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Install failed...

Expected results:
After identifying the raid array on the machine and providing a right kickstart, install will succeed.

Additional info:
This problem somewhat relateds to below one
https://bugzilla.redhat.com/show_bug.cgi?id=596582

Comment 1 Bill Peck 2010-05-27 13:31:13 UTC
This looks like a custom kickstart you passed in.  Are you sure the kickstart is valid?

Thanks

Comment 2 Bill Peck 2010-05-27 13:35:12 UTC
I did a quick look on the nay lab controller and there is a custom rhts_partitions for this host.

If this is not working correctly then you need to open a ticket with eng-ops@redhat.com

I can't do anything here.

Closing.


Note You need to log in before you can comment on or make changes to this bug.