Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 596691 - nss-pam-ldapd-0.7.5-2.fc13.x86_64 conflicts with file from package nss_ldap
Summary: nss-pam-ldapd-0.7.5-2.fc13.x86_64 conflicts with file from package nss_ldap
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nss-pam-ldapd
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-27 10:21 UTC by Lorenzo Sartoratti
Modified: 2010-06-20 23:37 UTC (History)
2 users (show)

Fixed In Version: nss-pam-ldapd-0.7.6-2.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-03 18:05:55 UTC


Attachments (Terms of Use)

Description Lorenzo Sartoratti 2010-05-27 10:21:04 UTC
Description of problem:
When I try to install nss-pam-ldapd with yum I have the following error:
Transaction Check Error:
  file /usr/lib64/libnss_ldap.so from install of nss-pam-ldapd-0.7.5-2.fc13.x86_64 conflicts with file from package nss_ldap-264-9.fc13.x86_64


How reproducible:
Install nss_ldap package
Install with yum nss-pam-ldapd package

  
Actual results:
Transaction Check Error:
  file /usr/lib64/libnss_ldap.so from install of nss-pam-ldapd-0.7.5-2.fc13.x86_64 conflicts with file from package nss_ldap-264-9.fc13.x86_64


Expected results:
No conflicts

Additional info:

Comment 1 Nalin Dahyabhai 2010-05-27 16:14:36 UTC
Applications will generally only be able to use one libnss_ldap.so.2, so it doesn't make much sense to have both of them installed.  This at least prevents any unintended switchovers which could happen if we added an "obsoletes:" tag to the nss-pam-ldapd package.

On my own system, I used 'yum shell' to switch over:
  yum shell
  > install nss-pam-ldapd
  > erase nss_ldap
  > run
  > quit

After that there's still the matter of starting the nslcd service.  So long as we continue to provide both packages, I'm not there's a way that we can do this more smoothly.

Comment 2 Dmitri Pal 2010-05-27 16:33:45 UTC
This is the intended behavior as described above. Would you mind closing the bug please?

Comment 3 Nalin Dahyabhai 2010-05-27 21:23:58 UTC
Oops, I forgot that the nss_ldap/pam_ldap split didn't happen in time for F13, so we depend on the nss_ldap package to provide the pam_ldap module.  Moving this to assigned.

Comment 4 Fedora Update System 2010-05-27 21:38:06 UTC
nss-pam-ldapd-0.7.6-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/nss-pam-ldapd-0.7.6-1.fc13

Comment 5 Nalin Dahyabhai 2010-05-27 22:58:42 UTC
The correct link for the update request is https://admin.fedoraproject.org/updates/nss-pam-ldapd-0.7.6-2.fc13 -- if you can test the package there, I'd appreciate it.  Thanks!

Comment 6 Lorenzo Sartoratti 2010-05-28 07:38:46 UTC
Ok
I see that there are two libraries named libnss_ldap.so.2
in /lib and /usr/lib.
Is it correct?
In this case you can close the bug.
Thank you!

Comment 7 Nalin Dahyabhai 2010-05-28 15:14:03 UTC
The libraries being in different locations avoids the file conflict, but when an application goes to use the "ldap" source, it will only ever get one or the other unless tricks are being played with $LD_LIBRARY_PATH (the locations work out so that by default, nss-pam-ldapd's module will tend to be found first), so you can't use both at the same time.

If it's all the same to you, I'll leave this open so that pushing the nss-pam-ldapd update to fix the file conflict will close it -- it's marginally easier to find open bugs than closed ones, as bugzilla's default search parameters don't include searching closed bugs, and I'm hoping people who run into the same problem before the update is pushed will find this report.

Comment 8 Fedora Update System 2010-05-28 17:53:48 UTC
nss-pam-ldapd-0.7.6-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nss-pam-ldapd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/nss-pam-ldapd-0.7.6-2.fc13

Comment 9 Fedora Update System 2010-06-03 18:05:50 UTC
nss-pam-ldapd-0.7.6-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Jens Petersen 2010-06-17 04:58:36 UTC
I am seeing the conflict when trying to install rawhide today:

file /usr/lib64/libnss_ldap.so conflicts between attempted installs of nss-pam-lapd-0.7.6-2.fc14.x86_64 and nss_ldap-265-4.fc14.x86_64.

Should I file a new bug for that?

Comment 11 Nalin Dahyabhai 2010-06-17 14:57:40 UTC
In Raw Hide they both require the pam_ldap module, which is now a separate package.  The big problem before the pam_ldap package was split out was that nss-pam-ldapd required nss_ldap (which provided the module) while at the same time conflicting with it at the file level.  In practice, it doesn't make sense to have both of them installed at the same time (libc will always just use the "first" one it finds), so a conflict, now that it's possible to not have both installed and still have both an nsswitch and PAM module, is probably okay.

Comment 12 Jens Petersen 2010-06-20 23:37:48 UTC
I see thanks: I filed bug 604978 for rawhide: maybe it is just a comps issue?


Note You need to log in before you can comment on or make changes to this bug.