Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 596673 - Ceases to display custom headers
Summary: Ceases to display custom headers
Keywords:
Status: CLOSED DUPLICATE of bug 585798
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 13
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-27 09:47 UTC by Nils Philippsen
Modified: 2010-06-16 10:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-16 10:00:27 UTC


Attachments (Terms of Use)
Screenshot exhibiting the problem (deleted)
2010-05-27 09:47 UTC, Nils Philippsen
no flags Details

Description Nils Philippsen 2010-05-27 09:47:32 UTC
Created attachment 417168 [details]
Screenshot exhibiting the problem

Description of problem:
I added a few custom headers (X-Bugzilla-...) to be displayed for mail messages, but they ceased to be displayed after upgrading from F-12 to F-13 unless "View -> All Message Headers" is enabled.

I noticed that the header names have been capitalization-normalized in the view (if displaying all message headers is selected), i.e. what originally is "X-Bugzilla-Product" is "X-bugzilla-product" in the normal view ("View -> Message Source" is unchanged however). I suspect that the evolution version in F-12 didn't change header capitalization and that the comparison is done case-sensitively.

Version-Release number of selected component (if applicable):
evolution-2.30.1-5.fc13.x86_64

Comment 1 Milan Crha 2010-05-27 12:43:39 UTC
Thanks for a bug report. there seems to be something with the update process, because when I try to enter this header by hand, then it works as expected, it's shown in the preview (after moving to other message and back, when changing the list of interested labels). I'm trying this with a code of gnome-2-30, which is something before 2.30.2.

Could you paste here content of your GConf entry
/apps/evolution/mail/display/headers
please? It's a place where headers list is stored. Thanks in advance.

Comment 2 nolan 2010-06-15 21:38:35 UTC
I hit this as well, with 2.30.1.2.  Only removing and adding the header by hand doesn't fix it for me.  Here is my /apps/evolution/mail/display/headers:

$ gconftool --get /apps/evolution/mail/display/headers
[<?xml version="1.0"?>
<header name="From" enabled=""/>
,<?xml version="1.0"?>
<header name="Reply-To" enabled=""/>
,<?xml version="1.0"?>
<header name="To" enabled=""/>
,<?xml version="1.0"?>
<header name="Cc" enabled=""/>
,<?xml version="1.0"?>
<header name="Bcc" enabled=""/>
,<?xml version="1.0"?>
<header name="Subject" enabled=""/>
,<?xml version="1.0"?>
<header name="Date" enabled=""/>
,<?xml version="1.0"?>
<header name="Newsgroups" enabled=""/>
,<?xml version="1.0"?>
<header name="Face"/>
,<?xml version="1.0"?>
<header name="x-evolution-mailer" enabled=""/>
,<?xml version="1.0"?>
<header name="X-Spam-Status" enabled=""/>
]

Comment 3 Nils Philippsen 2010-06-16 09:30:31 UTC
I've meanwhile added the headers with capitalization as found in a mail message in evolution, but to no avail. Here's my gconf entry for headers FWIW:


[<?xml version="1.0"?>
<header name="From" enabled=""/>
,<?xml version="1.0"?>
<header name="Reply-To" enabled=""/>
,<?xml version="1.0"?>
<header name="To" enabled=""/>
,<?xml version="1.0"?>
<header name="Cc" enabled=""/>
,<?xml version="1.0"?>
<header name="Bcc" enabled=""/>
,<?xml version="1.0"?>
<header name="Subject" enabled=""/>
,<?xml version="1.0"?>
<header name="Date" enabled=""/>
,<?xml version="1.0"?>
<header name="Newsgroups" enabled=""/>
,<?xml version="1.0"?>
<header name="Face" enabled=""/>
,<?xml version="1.0"?>
<header name="x-evolution-mailer" enabled=""/>
,<?xml version="1.0"?>
<header name="X-Bugzilla-Product" enabled=""/>
,<?xml version="1.0"?>
<header name="X-Bugzilla-Version" enabled=""/>
,<?xml version="1.0"?>
<header name="X-Bugzilla-Component" enabled=""/>
,<?xml version="1.0"?>
<header name="X-Bugzilla-Status" enabled=""/>
,<?xml version="1.0"?>
<header name="X-Calendar-Attachment" enabled=""/>
,<?xml version="1.0"?>
<header name="X-bugzilla-product" enabled=""/>
,<?xml version="1.0"?>
<header name="X-bugzilla-version" enabled=""/>
,<?xml version="1.0"?>
<header name="X-bugzilla-component" enabled=""/>
,<?xml version="1.0"?>
<header name="X-bugzilla-status" enabled=""/>
]

Comment 4 Milan Crha 2010-06-16 10:00:27 UTC
Thanks for the update. I found a previously filled bug report for this, thus I'm marking it as a duplicate. Just note that this should be fixed in 2.30.2+.

*** This bug has been marked as a duplicate of bug 585798 ***


Note You need to log in before you can comment on or make changes to this bug.