Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 596656 - [abrt] plymouth-0.8.3-3.el6: raise: Process /sbin/plymouthd was killed by signal 6 (SIGABRT)
Summary: [abrt] plymouth-0.8.3-3.el6: raise: Process /sbin/plymouthd was killed by sig...
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: plymouth
Version: 6.0
Hardware: s390x
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard: abrt_hash:f28321061560ee02104654a6e28...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-27 09:12 UTC by Michal Nowak
Modified: 2013-03-08 02:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-15 19:03:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-27 09:12 UTC, Michal Nowak
no flags Details

Description Michal Nowak 2010-05-27 09:12:02 UTC
abrt version: 1.1.4
architecture: s390x
Attached file: backtrace
cmdline: /sbin/plymouthd --mode=shutdown
component: plymouth
crash_function: raise
executable: /sbin/plymouthd
global_uuid: f28321061560ee02104654a6e28d0bc1a37d311a
kernel: 2.6.32-28.el6.s390x
package: plymouth-0.8.3-3.el6
rating: 4
reason: Process /sbin/plymouthd was killed by signal 6 (SIGABRT)
release: Red Hat Enterprise Linux Server release 6.0 Beta (Santiago)

Comment 1 Michal Nowak 2010-05-27 09:12:04 UTC
Created attachment 417156 [details]
File: backtrace

Comment 3 Bill Nottingham 2010-05-27 15:19:19 UTC
How reproducible is this?

Comment 4 RHEL Product and Program Management 2010-05-27 15:35:52 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 5 Michal Nowak 2010-05-28 09:00:55 UTC
No idea. Just found it after S/390x restart. I could have been the first restart after May 21 Plymouth update.

Comment 6 Ray Strode [halfline] 2010-06-01 14:43:17 UTC
next time you reboot can you add plymouth:debug to the kernel command line?

Comment 7 Michal Nowak 2010-06-02 10:39:01 UTC
So... It happens on shutdown after plymouth update.

[...]
Jun  2 06:26:05 auto-s390-001 yum: Updated: plymouth-theme-spinfinity-0.8.3-3.el6.s390x
Jun  2 06:26:05 auto-s390-001 yum: Updated: plymouth-theme-glow-0.8.3-3.el6.s390x
Jun  2 06:26:06 auto-s390-001 yum: Updated: plymouth-debuginfo-0.8.3-3.el6.s390x
Jun  2 06:26:12 auto-s390-001 abrtd: Getting crash infos...
Jun  2 06:26:16 auto-s390-001 init: tty (/dev/console) main process (2480) killed by TERM signal
Jun  2 06:26:16 auto-s390-001 abrt[2579]: saved core dump of pid 2572 (/sbin/plymouthd) to /var/spool/abrt/ccpp-1275474376-2572.new/coredump (1064960 bytes)
Jun  2 06:26:16 auto-s390-001 abrtd: Directory 'ccpp-1275474376-2572' creation detected
Jun  2 06:26:16 auto-s390-001 init: plymouth-shutdown main process (2570) terminated with status 2
Jun  2 06:26:16 auto-s390-001 init: splash-manager main process (2566) terminated with status 1
[...]

I added "plymouth:debug" to zipl.conf and updated it via `zipl`, however I don't see anything more in logs regarding plymouth. Where should I see those debug messages?

Comment 8 Ray Strode [halfline] 2010-06-02 12:54:31 UTC
oh sorry.  The log file is in /var/log/plymouth-debug.log

Of course, it will be for your boot up (which succeeds) not your shutdown (which fails).  It's still useful, though.

One thing I'm interested in is the output of /proc/cmdline, but that should be in the plymouth-debug.log

Comment 9 Michal Nowak 2010-06-02 14:10:54 UTC
(In reply to comment #8)
> oh sorry.  The log file is in /var/log/plymouth-debug.log

No such file, I am afraid.

> Of course, it will be for your boot up (which succeeds) not your shutdown
> (which fails).  It's still useful, though.
> 
> One thing I'm interested in is the output of /proc/cmdline, but that should be
> in the plymouth-debug.log    

[root@auto-s390-002 ~]# cat /proc/cmdline
root=/dev/mapper/vg_autos390002-lv_root rd_DASD=0.0.206e,use_diag=0,readonly=0,erplog=0,failfast=0 rd_DASD=0.0.216e,use_diag=0,readonly=0,erplog=0,failfast=0 rd_DASD=0.0.226e,use_diag=0,readonly=0,erplog=0,failfast=0 rd_DASD=0.0.236e,use_diag=0,readonly=0,erplog=0,failfast=0 rd_DASD=0.0.206f,use_diag=0,readonly=0,erplog=0,failfast=0 rd_DASD=0.0.216f,use_diag=0,readonly=0,erplog=0,failfast=0 rd_DASD=0.0.226f,use_diag=0,readonly=0,erplog=0,failfast=0 rd_DASD=0.0.236f,use_diag=0,readonly=0,erplog=0,failfast=0 rd_DASD=0.0.2070,use_diag=0,readonly=0,erplog=0,failfast=0 rd_DASD=0.0.2170,use_diag=0,readonly=0,erplog=0,failfast=0 rd_DASD=0.0.2270,use_diag=0,readonly=0,erplog=0,failfast=0 rd_DASD=0.0.2370,use_diag=0,readonly=0,erplog=0,failfast=0 rd_LVM_LV=vg_autos390002/lv_root rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 crashkernel=auto plymouth:debug BOOT_IMAGE


Tried both "plymouth:debug" and "plymouth=debug". With plymouth-0.8.3-1.el6.s390x.

Comment 10 Ray Strode [halfline] 2010-06-15 19:03:47 UTC

*** This bug has been marked as a duplicate of bug 601745 ***


Note You need to log in before you can comment on or make changes to this bug.