Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 596652 - cannot rebuild devhelp srpm if sqlite-devel is installed
Summary: cannot rebuild devhelp srpm if sqlite-devel is installed
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: devhelp
Version: 5.6
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Matthew Barnes
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
: 596650 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-27 09:06 UTC by Vladimir Benes
Modified: 2015-08-03 11:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:04:00 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Vladimir Benes 2010-05-27 09:06:17 UTC
Description of problem:
cannot rebuild devhelp due to bad --rpath ordering in the devhelp build

Version-Release number of selected component (if applicable):
devhelp-0.12-21.el5

x86_64 and s390x are affected afaik

Additional info:
see:
https://errata.devel.redhat.com/errata/show/9536#c186

Comment 1 Matěj Cepl 2010-05-29 15:10:05 UTC
Reporter, could you please give us URL of some failed scratch build, please? I am still not sure what exactly you mean by "bad --rpath ordering".

Thank you

Comment 2 Vladimir Benes 2010-05-31 11:33:54 UTC
http://nest.test.redhat.com/mnt/qa/scratch/x86-64-5c-m2/2010:9536/tps/?C=M;O=D

mail from jwl:

gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=g
eneric -o .libs/devhelp devhelp-dh-main.o -pthread  -L/lib64 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -
lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgconf-2 -lORBit-2 -lm -lgmodule-2.0 -ldl -lgthread-2.0 -lglib-2.0
 ./.libs/libdevhelp-1.so -Wl,--rpath -Wl,/usr/lib64 -Wl,--rpath -Wl,/usr/lib64/xulrunner-1.9.2
/usr/lib64/xulrunner-1.9.2/libxul.so: undefined reference to `sqlite3_shutdown'
/usr/lib64/xulrunner-1.9.2/libxul.so: undefined reference to `sqlite3_result_error_nomem'
/usr/lib64/xulrunner-1.9.2/libxul.so: undefined reference to `sqlite3_sql'
/usr/lib64/xulrunner-1.9.2/libxul.so: undefined reference to `sqlite3_prepare_v2'
/usr/lib64/xulrunner-1.9.2/libxul.so: undefined reference to `sqlite3_stmt_status'
/usr/lib64/xulrunner-1.9.2/libxul.so: undefined reference to `sqlite3_config'
/usr/lib64/xulrunner-1.9.2/libxul.so: undefined reference to `sqlite3_initialize'
/usr/lib64/xulrunner-1.9.2/libxul.so: undefined reference to `sqlite3_clear_bindings'
collect2: ld returned 1 exit status
make[3]: *** [devhelp] Error 1
make[3]: Leaving directory `/usr/src/redhat/BUILD/devhelp-0.12/src'

We also see:
.qa.[root@x86-64-5s-m1 tps]# ldd /usr/lib64/xulrunner-1.9.2/libxul.so
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00002ad98ab25000)
        libsqlite3.so => /usr/lib64/xulrunner-1.9.2/libsqlite3.so (0x00002ad98ad40000)

And via 'nm -D', we can see that libxul.so really does use (and require)
the libsqlite3.so found in the xulrunner directory above.

The problem here is a bug in the build scripts regarding rpath ordering:
see the gcc command above.  The correct command would be:
gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -o .libs/devhelp devhelp-dh-main.o -pthread  -L/lib64 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgconf-2 -lORBit-2 -lm -lgmodule-2.0 -ldl -lgthread-2.0 -lglib-2.0  ./.libs/libdevhelp-1.so -Wl,--rpath -Wl,/usr/lib64/xulrunner-1.9.2 -Wl,--rpath -Wl,/usr/lib64

Comment 3 Vladimir Benes 2010-06-08 13:15:59 UTC
*** Bug 596650 has been marked as a duplicate of this bug. ***

Comment 5 RHEL Product and Program Management 2010-08-09 19:12:41 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 6 RHEL Product and Program Management 2014-03-07 12:40:46 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 7 RHEL Product and Program Management 2014-06-02 13:04:00 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.