Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 596582 - Install exited abnormally with RHEL6.0-Snapshot-5_http-Server-x86_64
Summary: Install exited abnormally with RHEL6.0-Snapshot-5_http-Server-x86_64
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-27 03:01 UTC by Igor Zhang
Modified: 2010-05-27 14:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-27 14:07:07 UTC
Target Upstream Version:


Attachments (Terms of Use)
install log (deleted)
2010-05-27 03:03 UTC, Igor Zhang
no flags Details

Description Igor Zhang 2010-05-27 03:01:50 UTC
Description of problem:
Install exited abnormally with RHEL6.0-Snapshot-5_http-Server-x86_64 on machine intel-s3e3144-03.rhts.eng.nay.redhat.com

Version-Release number of selected component (if applicable):
RHEL6.0-Snapshot-5_http-Server-x86_64

How reproducible:
Just install RHEL6.0-Snapshot-5_http-Server-x86_64 on machine intel-s3e3144-03.rhts.eng.nay.redhat.com

Steps to Reproduce:
1.
2.
3.
  
Actual results:
...
Running anaconda 13.21.44, the Red Hat Enterprise Linux system installer - please wait.
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1013, in <module>
    anaconda.id = instClass.installDataClass(anaconda, extraModules, opts.display_mode, anaconda.backend)
  File "/usr/lib/anaconda/instdata.py", line 301, in __init__
    self.reset()
  File "/usr/lib/anaconda/instdata.py", line 64, in reset
    self.network = network.Network()
  File "/usr/lib/anaconda/network.py", line 317, in __init__
    self.update()
  File "/usr/lib/anaconda/network.py", line 326, in update
    devhash = isys.getDeviceProperties(dev=None)
  File "/usr/lib/anaconda/isys.py", line 392, in getDeviceProperties
    device_interface = str(device_props_iface.Get(NM_MANAGER_IFACE, "Interface"))
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: Interface "org.freedesktop.NetworkManager" isn't exported (or may not exist), can't access property "Interface"
install exited abnormally [1/1] 
The system will be rebooted when you press Ctrl-C or Ctrl-Alt-Delete.

Expected results:
Install RHEL6.0-Snapshot-5_http-Server-x86_64 successfully

Additional info:
With RHEL6.0-Snapshot-4_http-Server-x86_64 on this machine, I got following message:
...
Running anaconda 13.21.39, the Red Hat Enterprise Linux system installer - please wait.
Finding storage devices
anaconda 13.21.39 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/kickstart.py", line 711, in execute
    raise KickstartValueError, formatErrorMsg(self.lineno, msg="Partition requires a size specification")
  File "/usr/lib/anaconda/kickstart.py", line 1132, in execute
    obj.execute(self.anaconda)
  File "/usr/bin/anaconda", line 1094, in <module>
    ksdata.execute()
KickstartValueError: The following problem occurred on line 38 of the kickstart file:

Partition requires a size specification


install exited abnormally [1/1] 
The system will be rebooted when you press Ctrl-C or Ctrl-Alt-Delete.

Comment 1 Igor Zhang 2010-05-27 03:03:29 UTC
Created attachment 417096 [details]
install log

Comment 3 Chris Lumens 2010-05-27 03:40:33 UTC

*** This bug has been marked as a duplicate of bug 594716 ***

Comment 4 Igor Zhang 2010-05-27 06:18:40 UTC
With RHEL6.0-20100524.n.0_nfs-Server-x86_64, I got this either:
...
Looking for installation images on CD device /dev/sr0Running anaconda 13.21.45, the Red Hat Enterprise Linux system installer - please wait.
Finding storage devices
anaconda 13.21.45 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/kickstart.py", line 713, in execute
    raise KickstartValueError, formatErrorMsg(self.lineno, msg="Partition requires a size specification")
  File "/usr/lib/anaconda/kickstart.py", line 1134, in execute
    obj.execute(self.anaconda)
  File "/usr/bin/anaconda", line 1094, in <module>
    ksdata.execute()
KickstartValueError: The following problem occurred on line 39 of the kickstart file:

Partition requires a size specification


install exited abnormally [1/1] 
The system will be rebooted when you press Ctrl-C or Ctrl-Alt-Delete.

I doubt if initrd lacks the raid driver or not, which leads the kickstart file cannot be identified correctly.

Comment 5 Igor Zhang 2010-05-27 06:29:19 UTC
Ok, i find the distro RHEL6.0-20100523.0_nfs-Server-x86_64 in beaker and try that and still get the same error message, which someone said it had been verified with that distro.
https://bugzilla.redhat.com/show_bug.cgi?id=594716#c11

Comment 6 Igor Zhang 2010-05-27 14:07:07 UTC

*** This bug has been marked as a duplicate of bug 594716 ***


Note You need to log in before you can comment on or make changes to this bug.