Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 596531 - mkinitrd ignores /etc/modprobe.d/modprobe.conf
Summary: mkinitrd ignores /etc/modprobe.d/modprobe.conf
Keywords:
Status: CLOSED DUPLICATE of bug 564392
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd
Version: 5.5
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Peter Jones
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-26 21:36 UTC by Jeff Bastian
Modified: 2010-11-09 12:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-26 21:50:37 UTC
Target Upstream Version:


Attachments (Terms of Use)
patch for mkinitrd to look at /etc/modprobe.d/* (deleted)
2010-05-26 21:36 UTC, Jeff Bastian
no flags Details | Diff

Description Jeff Bastian 2010-05-26 21:36:58 UTC
Created attachment 417037 [details]
patch for mkinitrd to look at /etc/modprobe.d/*

Description of problem:
If modprobe.conf is moved to /etc/modprobe.d/ (since /etc/modprobe.conf is deprecated), mkinitrd ignores the file and generates a bad initrd image (i.e., it's missing modules).

Version-Release number of selected component (if applicable):
mkinitrd-5.1.19.6-61

How reproducible:
every time

Steps to Reproduce:
1. (if necessary) edit /etc/modprobe.conf and add a line to use the cciss module:
       alias scsi_hostadapter2 cciss
2. mv /etc/modprobe.conf /etc/modprobe.d/
3. mkinitrd -f --nocompress /tmp/initrd-testing.img `uname -r`
4. cpio -t < /tmp/initrd-testing.img | grep cciss
  
Actual results:
cciss module is not included in /tmp/initrd-testing.img

Expected results:
cciss module is included
   # cpio -t < /tmp/initrd-orig-etc_modprobe_conf.img | grep cciss
   17077 blocks
   lib/cciss.ko

Comment 1 Jeff Bastian 2010-05-26 21:50:37 UTC
Oops, I missed bug 564392 when searching earlier.

*** This bug has been marked as a duplicate of bug 564392 ***


Note You need to log in before you can comment on or make changes to this bug.