Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 596473 - failure trying to add PCI device to guest
Summary: failure trying to add PCI device to guest
Keywords:
Status: CLOSED DUPLICATE of bug 582752
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-26 19:34 UTC by Andy Gospodarek
Modified: 2014-06-29 23:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-26 19:38:25 UTC


Attachments (Terms of Use)
adding device (deleted)
2010-05-26 19:34 UTC, Andy Gospodarek
no flags Details
finishing device add (deleted)
2010-05-26 19:35 UTC, Andy Gospodarek
no flags Details
device incorrect in list (deleted)
2010-05-26 19:36 UTC, Andy Gospodarek
no flags Details
failure when starting guest (deleted)
2010-05-26 19:37 UTC, Andy Gospodarek
no flags Details

Description Andy Gospodarek 2010-05-26 19:34:15 UTC
Created attachment 417002 [details]
adding device

Description of problem:

Invalid device is added to the xml for the guest when using virt-manager to add a PCI device to a guest.

Trying to add 04:10.0 on my system results in 04:16.0, so it seems and an unnecessary dev->hex conversion is done.  The device appears to be added correctly, but when starting the guest, I get the following error:

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 799, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 1256, in startup
    self._backend.create()
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 317, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: this function is not supported by the hypervisor: Failed to read product/vendor ID for 0000:04:16.0

If I used 'virsh edit rawhide-test' to edit the slot back to 0x10, the guest boots just fine.

Version-Release number of selected component (if applicable):

virt-manager-0.8.3-3.fc13.noarch
libvirt-0.7.7-3.fc13.x86_64

How reproducible:

Every time.

Steps to Reproduce:

See attached screenshots.

Comment 1 Andy Gospodarek 2010-05-26 19:35:15 UTC
Created attachment 417003 [details]
finishing device add

Comment 2 Andy Gospodarek 2010-05-26 19:36:16 UTC
Created attachment 417005 [details]
device incorrect in list

Comment 3 Andy Gospodarek 2010-05-26 19:37:29 UTC
Created attachment 417006 [details]
failure when starting guest

Comment 4 Cole Robinson 2010-05-26 19:38:25 UTC
Should be fixed by the libvirt version in updates-testing.

*** This bug has been marked as a duplicate of bug 582752 ***

Comment 5 Andy Gospodarek 2010-05-26 19:40:59 UTC
Thanks, Cole.  Does this problem exist in RHEL6 too?

Comment 6 Cole Robinson 2010-05-26 19:46:43 UTC
Nope, RHEL6 libvirt is several releases ahead and has this fix already.


Note You need to log in before you can comment on or make changes to this bug.