Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 596377 - Missing -static subpackage
Summary: Missing -static subpackage
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: e2fsprogs
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Eric Sandeen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 596926 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-26 17:05 UTC by Roman Rakus
Modified: 2014-01-13 00:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-02 20:24:14 UTC


Attachments (Terms of Use)

Description Roman Rakus 2010-05-26 17:05:35 UTC
Description of problem:
Yaboot needs static library of ext2fs

Once you add it I will change the BuildRequires in yaboot from e2fsprogs-devel to e2fsprogs-static

Comment 1 Eric Sandeen 2010-06-01 17:34:09 UTC
*** Bug 596926 has been marked as a duplicate of this bug. ***

Comment 2 Eric Sandeen 2010-06-01 17:35:58 UTC
Sorry about that, in bug 545144, Michael looked but thought that no Fedora packages required static libs, so I removed them.

I'll look into making a -static package for yaboot.

-Eric

Comment 3 Christophe GRENIER 2010-06-01 17:52:34 UTC
> Eric Sandeen wrote:
> out of curiosity, which utilities do you have which require static e2fsprogs
> libs on fedora?

My package testdisk is using the shared libs. But on my website I also provides static binaries of TestDisk & PhotoRec for Linux users using non-Fedora distributions. Without this package, it can't create static version
anymore. The library is used by TestDisk to list the content of recovered ext2/ext3/ext4 partition or by PhotoRec to carve files from the free/unallocated space of the filesystem.

Comment 4 Eric Sandeen 2010-06-01 17:57:07 UTC
Ok thanks, just curious.  I'll try to get this taken care of soon.

Comment 5 Eric Sandeen 2010-06-02 18:58:10 UTC
Requested FESCO approval for the -static package:
https://fedorahosted.org/fesco/ticket/388

-Eric

Comment 6 Eric Sandeen 2010-06-02 20:24:14 UTC
Ok, an e2fsprogs-static subpackage should appear shortly in rawhide & koji.

Is this needed for F13?

Comment 7 Christophe GRENIER 2010-06-03 05:39:51 UTC
Life would be easier if an e2fsprogs-static subpackage was available for F13. Otherwise I will install the rawhide package and be carefull during futur update...

Comment 8 Roman Rakus 2010-06-03 15:23:08 UTC
Thank you. Yaboot build is now ok.
I'm not going to (re)build yaboot on f-13.


Note You need to log in before you can comment on or make changes to this bug.