Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 596311 - 7.20.5.1. shows a size for /boot partition which is too small for preupgrade
Summary: 7.20.5.1. shows a size for /boot partition which is too small for preupgrade
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: install-guide
Version: devel
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Nalley
QA Contact: Ruediger Landmann
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-26 15:10 UTC by Domingo Becker
Modified: 2010-10-31 16:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-30 17:00:42 UTC


Attachments (Terms of Use)

Description Domingo Becker 2010-05-26 15:10:27 UTC
Description of problem:
In section 7.20.5.1. there's a recommended size for /boot partition of 250MB.
That size is not enough for preupgrade, because it tries to put there the new boot installer image.
I tested it under Fedora 12 i386.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 PRABIN KUMAR DATTA 2010-10-30 17:00:42 UTC
Please check this line "For most users, a 250 MB boot partition is sufficient."

250MB is enough for boot partition. 

Note: 
If somehow this partition filled up,
1. delete all the old version of kernel's config-*, initramfs-*, System.map-*, vmliniz-* files.
Or,
2. Move all the old version of kernel's config-*, initramfs-*, System.map-*, vmliniz-* file to another partition. Then edit the /boot/grub/menu.lst file as root and provide the path for new partition.
Or,
3. you can install the new version of kernel on another partition. Then, edit the /boot/grub/menu.lst file as root and provide the path for new partition.

Comment 2 Domingo Becker 2010-10-31 16:13:43 UTC
Prabin,

You can ask to do that to me, but not to an end user.
Most end users act in a different way and they expect things to be easier.

I use Fedora since Core 1, however, I made the mistake to set a /boot partition of 250MB because I read it in install guide.

Kernel updates are ok with this partition size, but not preupgrade, my preferred method for updating Fedora releases, which keeps all previous configuration, reducing the maintenance time needed for upgrading Fedora office desktops.

I consider preupgrade a Fedora success.
If you follow this recommendation, it will disable the possibility of using preupgrade.
Humbly, I think we should not induce users to do things against the preferred and best way of using Fedora.

kind regards


Note You need to log in before you can comment on or make changes to this bug.