Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 596072 - Gtk-Message: Failed to load module "pk-gtk-module": libpk-gtk-module.so: cannot open shared object file: No such file or directory
Summary: Gtk-Message: Failed to load module "pk-gtk-module": libpk-gtk-module.so: cann...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pygtk2
Version: 6.0
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Matthew Barnes
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-26 09:24 UTC by Jan Pazdziora
Modified: 2017-10-18 07:31 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-18 07:31:07 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Pazdziora 2010-05-26 09:24:15 UTC
Description of problem:

When running import gtk in RHEL 6, warning

Gtk-Message: Failed to load module "pk-gtk-module": libpk-gtk-module.so: cannot open shared object file: No such file or directory

is shown.

Version-Release number of selected component (if applicable):

# rpm -q pygtk2
pygtk2-2.16.0-3.el6.i686

How reproducible:

Deterministic.

Steps to Reproduce:
1. # python -c 'import gtk'
  
Actual results:

Gtk-Message: Failed to load module "pk-gtk-module": libpk-gtk-module.so: cannot open shared object file: No such file or directory

Expected results:

No warning.

Additional info:

Comment 1 Matthew Barnes 2010-06-08 18:29:30 UTC
I'm unable to reproduce this warning on a clean RHEL6 install.

The warning just means GTK+ is unable to load the PackageKit module, which is provided by the "PackageKit-gtk-module" package:

    $ rpm -ql PackageKit-gtk-module
    /usr/lib/gtk-2.0/modules/libpk-gtk-module.so
    ...

The "gnome-packagekit" package installs the GConf key

    /apps/gnome_settings_daemon/gtk-modules/pk-gtk-module

which is what tells GTK+ to try to load the PackageKit module in the first place.

This sounds like a configuration issue on your system.  Can you verify that these two packages are installed?

Comment 2 Jan Pazdziora 2010-06-09 15:31:29 UTC
I don't have PackageKit-gtk-module nor gnome-packagekit installed:

[root@vmware178 ~]# rpm -qf /usr/lib/gtk-2.0/modules/libpk-gtk-module.so
error: file /usr/lib/gtk-2.0/modules/libpk-gtk-module.so: No such file or directory
[root@vmware178 ~]# rpm -q gnome-packagekit
package gnome-packagekit is not installed
[root@vmware178 ~]# rpm -q pygtk2
pygtk2-2.16.0-3.el6.i686
[root@vmware178 ~]# python -c 'import gtk'
Gtk-Message: Failed to load module "pk-gtk-module": libpk-gtk-module.so: cannot open shared object file: No such file or directory
[root@vmware178 ~]# rpm -q PackageKit-gtk-module
package PackageKit-gtk-module is not installed
[root@vmware178 ~]# 

That's what's interesting -- the package dependencies allowed me to install the packages this way, yet I still get error about that pk-gtk-module thing.

Comment 3 Matthias Clasen 2010-06-09 15:38:25 UTC
Its a harmless message. Clearly not a blocker.

Comment 6 RHEL Product and Program Management 2010-06-11 21:14:44 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Comment 7 Jan Pazdziora 2010-06-14 10:00:17 UTC
I do not agree that this is user environment issue.

Yes, if I install PackageKit-gtk-module (which pulls in libarchive comps-extras PackageKit-yum-plugin PackageKit-yum PackageKit-glib PackageKit), the message goes away. But if I remove them again, the message is back. And there is no dependency which would prevent me from doing that.

So something in the way pygtk2 (or maybe other package) is built assumes PackageKit-gtk-module installed (or at least one file from that package) which is incorrect and signals some packaging problem.

If you want updated Steps to Reproduce, they will be something like:

1. Make sure pygtk2 is installed.
2. Make sure PackageKit-gtk-module and its dependencies are not installed:
   # yum remove libarchive comps-extras PackageKit-yum-plugin PackageKit-yum PackageKit-glib PackageKit PackageKit-gtk-module
3. Run # python -c 'import gtk'

Reopening per advice in comment 6, setting flag rhel‑6.1.0.

Comment 8 Richard Hughes 2010-06-14 12:38:31 UTC
Can you try doing:

gconftool-2 -u /apps/gnome_settings_daemon/gtk-modules/pk-gtk-module

And then logging out and back in.

Comment 9 Jan Pazdziora 2010-06-14 12:57:11 UTC
(In reply to comment #8)
> Can you try doing:
> 
> gconftool-2 -u /apps/gnome_settings_daemon/gtk-modules/pk-gtk-module
> 
> And then logging out and back in.    

Done that on that RHEL 6, no change.

Ummm, am I supposed to run the command on my local workstation (Fedora 12) or on the virtual machine (RHEL 6)?

Comment 10 RHEL Product and Program Management 2011-01-07 15:32:15 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 11 RHEL Product and Program Management 2013-10-14 01:20:31 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 12 Jan Pazdziora 2017-10-18 07:31:07 UTC
Closing.


Note You need to log in before you can comment on or make changes to this bug.