Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 596010 - gdm-greeter doesn't display login box after yum upgrade to f13
Summary: gdm-greeter doesn't display login box after yum upgrade to f13
Keywords:
Status: CLOSED DUPLICATE of bug 590456
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: jmccann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-26 06:24 UTC by Henrique Martins
Modified: 2015-01-14 23:25 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-30 20:06:51 UTC


Attachments (Terms of Use)

Description Henrique Martins 2010-05-26 06:24:47 UTC
Description of problem:
yum upgraded to F13, no apparent problems but I don't have a login box.  New background is there, bottom bar with off button displays, but instead of a login box I have a one to two pixel vertical with line in the middle of the screen, as tall as probably the login box used to be.

Also telinit 3 from the Alt-Fx console yields an error message claiming that the greeter is still running, clicking on the box/accepting the error makes it go away but X never dies until I kill it.

Using xdm meanwhile

Version-Release number of selected component (if applicable):
gdm-2.30.2-1.fc13.i686

How reproducible:
always

Steps to Reproduce:
1. reboot, wait for login screen
2.
3.
  
Actual results:
No login box

Expected results:
Login box

Additional info:
F12 had user list and sound disabled for the greeter, not sure if that makes a difference

Comment 1 Henrique Martins 2010-05-26 14:01:52 UTC
Debugged this this morning and culprit is gdm/simple-greeter with disable_user_list set to true.

If I set the value of that option to true in
  /etc/gconf/gconf.xml.mandatory/apps/gdm/simple-greeter/%gconf.xml
as in

<?xml version="1.0"?>
<gconf>
  <entry name="disable_user_list" mtime="1263745615" type="bool" value="true"/>
</gconf>

and telinit 3/telinit 5 to restart gdm, the simple-greeter login box is a single vertical line, mostly one pixel wide, with a couple of 2 pixel wide sections.

If I change the file to have value="false", the default, and restart gdm again, the login box is back to normal, albeit with the user list I don't want to see.

Reproduced it twice, so it seems symptomatic.

Comment 2 Roy Rankin 2010-05-28 03:29:05 UTC
I have the same issue with disable_user_list set to true after preupgrade FC12->FC13

Comment 3 John Heidemann 2010-05-28 20:54:38 UTC
This bug is a show-stopper on F13 with disable_user_list set to true.

gdm is crashing and the process table fills up processes that contain "pam" and "gdm" on the command line.  In a few minutes these processes bring the system to a crawl, preventing logins over the network or from another virtual console.

Some relevant lines from /var/log/messages:

May 28 13:01:55 dash gdm-simple-greeter[1829]: Gtk-WARNING: gtkwidget.c:5643: widget not within a GtkWindow

May 28 13:01:57 dash gdm[1851]: ******************* START **********************************
May 28 13:01:58 dash gdm[1851]: [Thread debugging using libthread_db enabled]
May 28 13:01:58 dash gdm[1851]: [New Thread 0x7f22eb6ec710 (LWP 1834)]
May 28 13:01:59 dash gdm[1851]: 0x00007f22fa60bfdd in waitpid () from /lib64/libpthread.so.0
May 28 13:01:59 dash gdm[1851]: #0  0x00007f22fa60bfdd in waitpid () from /lib64/libpthread.so.0
May 28 13:01:59 dash gdm[1851]: #1  0x00000000004312bb in ?? ()
May 28 13:01:59 dash gdm[1851]: #2  0x0000000000431367 in ?? ()
May 28 13:01:59 dash gdm[1851]: #3  <signal handler called>
May 28 13:01:59 dash gdm[1851]: #4  0x00007f22f7a8f0f2 in __strlen_sse2 () from /lib64/libc.so.6
May 28 13:01:59 dash gdm[1851]: #5  0x00007f22f7dea3b2 in g_strdup () from /lib64/libglib-2.0.so.0
May 28 13:01:59 dash gdm[1851]: #6  0x00007f22f80bbcdd in ?? () from /lib64/libgobject-2.0.so.0
May 28 13:01:59 dash gdm[1851]: #7  0x00007f22f80aab29 in g_signal_emit_valist ()
May 28 13:01:59 dash gdm[1851]:    from /lib64/libgobject-2.0.so.0
May 28 13:01:59 dash gdm[1851]: #8  0x00007f22f80ab3a3 in g_signal_emit () from /lib64/libgobject-2.0.so.0
May 28 13:01:59 dash gdm[1851]: #9  0x000000000041f1cc in ?? ()
May 28 13:01:59 dash gdm[1851]: #10 0x00007f22f809598e in g_closure_invoke () from /lib64/libgobject-2.0.so.0
May 28 13:01:59 dash gdm[1851]: #11 0x00007f22f80a9947 in ?? () from /lib64/libgobject-2.0.so.0
May 28 13:01:59 dash gdm[1851]: #12 0x00007f22f80aade6 in g_signal_emit_valist ()
May 28 13:01:59 dash gdm[1851]:    from /lib64/libgobject-2.0.so.0
May 28 13:01:59 dash gdm[1851]: #13 0x00007f22f80ab3a3 in g_signal_emit () from /lib64/libgobject-2.0.so.0
May 28 13:01:59 dash gdm[1851]: #14 0x0000000000419936 in ?? ()
May 28 13:01:59 dash gdm[1851]: #15 0x000000000041a455 in ?? ()
May 28 13:01:59 dash gdm[1851]: #16 0x00007f22fa8299d6 in dbus_connection_dispatch ()
May 28 13:01:59 dash gdm[1851]:    from /lib64/libdbus-1.so.3
May 28 13:01:59 dash gdm[1851]: #17 0x00007f22faa63a25 in ?? () from /usr/lib64/libdbus-glib-1.so.2
May 28 13:01:59 dash gdm[1851]: #18 0x00007f22f7dc9d02 in g_main_context_dispatch ()
May 28 13:01:59 dash gdm[1851]:    from /lib64/libglib-2.0.so.0
May 28 13:01:59 dash gdm[1851]: #19 0x00007f22f7dcdae8 in ?? () from /lib64/libglib-2.0.so.0
May 28 13:01:59 dash gdm[1851]: #20 0x00007f22f7dcdff5 in g_main_loop_run () from /lib64/libglib-2.0.so.0
May 28 13:01:59 dash gdm[1851]: #21 0x00007f22fa0ce3c7 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
May 28 13:01:59 dash gdm[1851]: #22 0x00000000004123f4 in ?? ()
May 28 13:01:59 dash gdm[1851]: #23 0x00007f22f7a2dc5d in __libc_start_main () from /lib64/libc.so.6
May 28 13:01:59 dash gdm[1851]: #24 0x0000000000411fd9 in ?? ()
May 28 13:01:59 dash gdm[1851]: #25 0x00007fff1ce691f8 in ?? ()
May 28 13:01:59 dash gdm[1851]: #26 0x000000000000001c in ?? ()
May 28 13:01:59 dash gdm[1851]: #27 0x0000000000000001 in ?? ()
May 28 13:01:59 dash gdm[1851]: #28 0x00007fff1ce6ac3e in ?? ()
May 28 13:01:59 dash gdm[1851]: #29 0x0000000000000000 in ?? ()
May 28 13:01:59 dash gdm[1851]: 
May 28 13:01:59 dash gdm[1851]: Thread 2 (Thread 0x7f22eb6ec710 (LWP 1834)):
May 28 13:01:59 dash gdm[1851]: #0  0x00007f22fa608729 in pthread_cond_timedwait@@GLIBC_2.3.2 ()
May 28 13:01:59 dash gdm[1851]:    from /lib64/libpthread.so.0
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #1  0x00007f22f780d382 in ?? () from /lib64/libgthread-2.0.so.0
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #2  0x00007f22f7da50b1 in ?? () from /lib64/libglib-2.0.so.0
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #3  0x00007f22f7da51f7 in g_async_queue_timed_pop ()
May 28 13:01:59 dash gdm[1851]:    from /lib64/libglib-2.0.so.0
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #4  0x00007f22f7df4cba in ?? () from /lib64/libglib-2.0.so.0
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #5  0x00007f22f7df2e84 in ?? () from /lib64/libglib-2.0.so.0
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #6  0x00007f22fa604761 in start_thread () from /lib64/libpthread.so.0
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #7  0x00007f22f7af050d in clone () from /lib64/libc.so.6
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: 
May 28 13:01:59 dash gdm[1851]: Thread 1 (Thread 0x7f22fb06c8e0 (LWP 1829)):
May 28 13:01:59 dash gdm[1851]: #0  0x00007f22fa60bfdd in waitpid () from /lib64/libpthread.so.0
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #1  0x00000000004312bb in ?? ()
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #2  0x0000000000431367 in ?? ()
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #3  <signal handler called>
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #4  0x00007f22f7a8f0f2 in __strlen_sse2 () from /lib64/libc.so.6
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #5  0x00007f22f7dea3b2 in g_strdup () from /lib64/libglib-2.0.so.0
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #6  0x00007f22f80bbcdd in ?? () from /lib64/libgobject-2.0.so.0
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #7  0x00007f22f80aab29 in g_signal_emit_valist ()
May 28 13:01:59 dash gdm[1851]:    from /lib64/libgobject-2.0.so.0
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #8  0x00007f22f80ab3a3 in g_signal_emit () from /lib64/libgobject-2.0.so.0
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #9  0x000000000041f1cc in ?? ()
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #10 0x00007f22f809598e in g_closure_invoke () from /lib64/libgobject-2.0.so.0
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #11 0x00007f22f80a9947 in ?? () from /lib64/libgobject-2.0.so.0
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #12 0x00007f22f80aade6 in g_signal_emit_valist ()
May 28 13:01:59 dash gdm[1851]:    from /lib64/libgobject-2.0.so.0
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #13 0x00007f22f80ab3a3 in g_signal_emit () from /lib64/libgobject-2.0.so.0
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #14 0x0000000000419936 in ?? ()
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #15 0x000000000041a455 in ?? ()
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #16 0x00007f22fa8299d6 in dbus_connection_dispatch ()
May 28 13:01:59 dash gdm[1851]:    from /lib64/libdbus-1.so.3
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #17 0x00007f22faa63a25 in ?? () from /usr/lib64/libdbus-glib-1.so.2
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #18 0x00007f22f7dc9d02 in g_main_context_dispatch ()
May 28 13:01:59 dash gdm[1851]:    from /lib64/libglib-2.0.so.0
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #19 0x00007f22f7dcdae8 in ?? () from /lib64/libglib-2.0.so.0
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #20 0x00007f22f7dcdff5 in g_main_loop_run () from /lib64/libglib-2.0.so.0
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #21 0x00007f22fa0ce3c7 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #22 0x00000000004123f4 in ?? ()
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #23 0x00007f22f7a2dc5d in __libc_start_main () from /lib64/libc.so.6
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #24 0x0000000000411fd9 in ?? ()
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #25 0x00007fff1ce691f8 in ?? ()
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #26 0x000000000000001c in ?? ()
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #27 0x0000000000000001 in ?? ()
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #28 0x00007fff1ce6ac3e in ?? ()
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: #29 0x0000000000000000 in ?? ()
May 28 13:01:59 dash gdm[1851]: No symbol table info available.
May 28 13:01:59 dash gdm[1851]: A debugging session is active.
May 28 13:01:59 dash gdm[1851]: 
May 28 13:01:59 dash gdm[1851]: #011Inferior 1 [process 1829] will be detached.
May 28 13:01:59 dash gdm[1851]: 
May 28 13:01:59 dash gdm[1851]: Quit anyway? (y or n) [answered Y; input not from terminal]
May 28 13:01:59 dash gdm[1851]: ******************* END **********************************
May 28 13:01:59 dash gdm-simple-greeter[1857]: Gtk-WARNING: gtkwidget.c:5643: widget not within a GtkWindow
May 28 13:01:59 dash gdm-simple-slave[1685]: WARNING: Freeing conversation with active job
May 28 13:01:59 dash gdm[1862]: ******************* START **********************************
May 28 13:01:59 dash gdm[1862]: [Thread debugging using libthread_db enabled]
May 28 13:01:59 dash gdm[1862]: [New Thread 0x7fcc8f48c710 (LWP 1858)]
May 28 13:01:59 dash gdm[1862]: 0x00007fcc9e3abfdd in waitpid () from /lib64/libpthread.so.0

etc. ad infinitum

Comment 4 John Heidemann 2010-05-28 20:56:25 UTC
Continuing comment #3

work-around is the usual: give-up on gdm and switch to kdm (via DISPLAYMANAGER=KDE in /etc/sysconfig/desktop), or turn off disable_user_list

Also, given that this bricks a system without work-around, perhaps severity should be high.

Comment 5 Jeff Bastian 2010-05-30 18:07:14 UTC
This looks like a duplicate of bug 590456

Comment 6 Henrique Martins 2010-05-30 20:06:51 UTC

*** This bug has been marked as a duplicate of bug 590456 ***


Note You need to log in before you can comment on or make changes to this bug.