Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595945 - [abrt] crash in system-config-printer-1.2.1-1.fc13: system-config-printer.py:3607:checkNPName:AttributeError: GUI instance has no attribute 'printers'
Summary: [abrt] crash in system-config-printer-1.2.1-1.fc13: system-config-printer.py:...
Keywords:
Status: CLOSED DUPLICATE of bug 589793
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:7d549825
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-26 00:01 UTC by Kendale Perry
Modified: 2010-05-26 09:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-26 09:05:43 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-26 00:01 UTC, Kendale Perry
no flags Details

Description Kendale Perry 2010-05-26 00:01:43 UTC
abrt 1.1.0 detected a crash.

architecture: i686
cmdline: python /usr/share/system-config-printer/system-config-printer.py
component: system-config-printer
executable: /usr/share/system-config-printer/system-config-printer.py
kernel: 2.6.33.3-85.fc13.i686.PAE
package: system-config-printer-1.2.1-1.fc13
reason: system-config-printer.py:3607:checkNPName:AttributeError: GUI instance has no attribute 'printers'
release: Fedora release 13 (Goddard)

backtrace
-----
system-config-printer.py:3607:checkNPName:AttributeError: GUI instance has no attribute 'printers'

Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 6331, in on_tvNPModels_cursor_changed
    self.on_tvNPDrivers_cursor_changed(self.tvNPDrivers)
  File "/usr/share/system-config-printer/system-config-printer.py", line 6334, in on_tvNPDrivers_cursor_changed
    self.setNPButtons()
  File "/usr/share/system-config-printer/system-config-printer.py", line 4655, in setNPButtons
    self.mainapp.checkNPName(self.entNPName.get_text()))
  File "/usr/share/system-config-printer/system-config-printer.py", line 3607, in checkNPName
    for printer in self.printers.values():
AttributeError: GUI instance has no attribute 'printers'

Local variables in innermost frame:
self: <__main__.GUI instance at 0xa1e6d4c>
name: u'hp-officejet-7300-series'

How to reproduce
-----
1.Added printer
2.
3.

Comment 1 Kendale Perry 2010-05-26 00:01:45 UTC
Created attachment 416588 [details]
File: backtrace

Comment 2 Jiri Popelka 2010-05-26 09:05:43 UTC

*** This bug has been marked as a duplicate of bug 589793 ***


Note You need to log in before you can comment on or make changes to this bug.