Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595932 - RHEL6 developer workstation in a VM doesn't connect to the network
Summary: RHEL6 developer workstation in a VM doesn't connect to the network
Keywords:
Status: CLOSED DUPLICATE of bug 594494
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Daniel Veillard
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-25 23:00 UTC by jmccann
Modified: 2015-01-14 23:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-26 12:21:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description jmccann 2010-05-25 23:00:45 UTC
Description of problem:
I just installed the developer workstation package set from a RHEL6 nightly in a VM on a F13 host.  After installation the system isn't able to connect to the network.  ifcfg-eth0 had ONBOOT=no and NM_CONTROLLED=no.  Once those were changed and NM restarted the guest got an IP address.  However, it wasn't able to resolve hostnames.

The developer workstation enables libvirtd by default.  This seems to set up virtbr0 and dnsmasq in the guest.  The host system was also running dnsmasq with the same listen address.

Once I uninstall libvirtd and turn off dnsmasq, NM is able to connect to the host network fine.

Steps to Reproduce:
1. Create VM in F13
2. Install RHEL6 nightly "developer workstation"
3. Boot guest and login

Comment 2 Chris Lalancette 2010-05-26 12:21:09 UTC
Yeah, this is an ongoing problem.  Cole has been working on a fix in BZ 594494.  Closing this as a dup.

Chris Lalancette

*** This bug has been marked as a duplicate of bug 594494 ***


Note You need to log in before you can comment on or make changes to this bug.