Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595920 - Broken Dependency
Summary: Broken Dependency
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libguestfs
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 596250 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-25 22:16 UTC by David Le Sage
Modified: 2012-07-03 10:40 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-26 08:51:27 UTC


Attachments (Terms of Use)

Description David Le Sage 2010-05-25 22:16:12 UTC
Description of problem:
Running yum update results in the following error:


--> Running transaction check
---> Package openssl.i686 0:1.0.0-4.fc13 set to be updated
--> Processing Dependency: /usr/lib/.libcrypto.so.1.0.0.hmac for package: 1:libguestfs-1.2.5-2.fc13.i686
--> Processing Dependency: /usr/lib/.libcrypto.so.10.hmac for package: 1:libguestfs-1.2.5-2.fc13.i686
--> Processing Dependency: /usr/lib/libcrypto.so.10 for package: 1:libguestfs-1.2.5-2.fc13.i686
--> Finished Dependency Resolution
Error: Package: 1:libguestfs-1.2.5-2.fc13.i686 (@updates-testing)
           Requires: /usr/lib/.libcrypto.so.10.hmac
           Removing: openssl-1.0.0-1.fc13.i686 (@updates-testing)
Error: Package: 1:libguestfs-1.2.5-2.fc13.i686 (@updates-testing)
           Requires: /usr/lib/.libcrypto.so.1.0.0.hmac
           Removing: openssl-1.0.0-1.fc13.i686 (@updates-testing)
Error: Package: 1:libguestfs-1.2.5-2.fc13.i686 (@updates-testing)
           Requires: /usr/lib/libcrypto.so.10
           Removing: openssl-1.0.0-1.fc13.i686 (@updates-testing)
 You could try using --skip-broken to work around the problem

Comment 1 Tomas Mraz 2010-05-26 06:38:02 UTC
This must be fixed in libguestfs. The .hmac file for libcrypto is now in /lib{64,} The change of the placement of the .hmac file was forced by the fix for bug 559953.

Comment 2 Richard W.M. Jones 2010-05-26 08:51:27 UTC
This is long fixed.  Please try the newer versions of libguestfs
in updates-testing, eg:

https://admin.fedoraproject.org/updates/libguestfs-1.2.8-1.fc13

Comment 3 Richard W.M. Jones 2010-05-26 14:48:34 UTC
*** Bug 596250 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.