Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595908 - [abrt] crash in yum-3.2.27-4.fc13: fastestmirror.py:121:clean_hook:OSError: [Errno 13] Permission denied: '/var/cache/yum/i386/13/timedhosts.txt'
Summary: [abrt] crash in yum-3.2.27-4.fc13: fastestmirror.py:121:clean_hook:OSError: [...
Keywords:
Status: CLOSED DUPLICATE of bug 537829
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b31d9069
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-25 21:48 UTC by David Wald
Modified: 2014-01-21 23:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-26 04:31:17 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-25 21:48 UTC, David Wald
no flags Details

Description David Wald 2010-05-25 21:48:06 UTC
abrt 1.1.0 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/bin/yum clean all
component: yum
executable: /usr/bin/yum
kernel: 2.6.33.4-95.fc13.i686.PAE
package: yum-3.2.27-4.fc13
reason: fastestmirror.py:121:clean_hook:OSError: [Errno 13] Permission denied: '/var/cache/yum/i386/13/timedhosts.txt'
release: Fedora release 13 (Goddard)

backtrace
-----
fastestmirror.py:121:clean_hook:OSError: [Errno 13] Permission denied: '/var/cache/yum/i386/13/timedhosts.txt'

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 254, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 109, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 356, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 538, in doCommand
    return base.cleanCli(extcmds)
  File "/usr/share/yum-cli/cli.py", line 902, in cleanCli
    self.plugins.run('clean')
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 177, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fastestmirror.py", line 121, in clean_hook
    os.unlink(hostfilepath)
OSError: [Errno 13] Permission denied: '/var/cache/yum/i386/13/timedhosts.txt'

Local variables in innermost frame:
conduit: <yum.plugins.PluginConduit instance at 0x87a80ac>

How to reproduce
-----
1. yum clean all
2.
3.

Comment 1 David Wald 2010-05-25 21:48:08 UTC
Created attachment 416567 [details]
File: backtrace

Comment 2 Tim Lauridsen 2010-05-26 04:31:17 UTC
fixed upstream, will be released soon

use 'yum clean all' as root to clean the fastestmirror timing file for now

*** This bug has been marked as a duplicate of bug 537829 ***


Note You need to log in before you can comment on or make changes to this bug.