Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595870 - if there's an email to be recovered and imap password is not saved, imap password box pops up on top & doesn't accept input
Summary: if there's an email to be recovered and imap password is not saved, imap pass...
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution
Version: 6.0
Hardware: All
OS: Linux
Target Milestone: rc
: ---
Assignee: Matthew Barnes
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 2010-05-25 20:04 UTC by Máirín Duffy
Modified: 2010-06-07 17:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2010-06-07 17:25:23 UTC
Target Upstream Version:

Attachments (Terms of Use)

Description Máirín Duffy 2010-05-25 20:04:51 UTC
A little bit about how I have evolution set up:

- I use IMAP
- I do not save my password in evolution (my preference), evolution prompts me to type it in every morning

So here's the trouble:

Evolution crashed on me in the middle of writing an email. Whoops. So I started evolution back up. First (and this all happens very quickly), a dialog pops up asking me if I'd like to recover the email I was working on (AWESOME). However, then the IMAP password dialog box pops up on top of that.

However, the IMAP password dialog box does not accept input despite being on top. Somehow the 'Recover' dialog steals focus from it.

I was able to recover, but this scenario (albeit, rare as it is) could use a little polish. When a window doesn't accept input it can be very jarring.

Version-Release number of selected component (if applicable):

How reproducible:

I can't seem to reproduce it, because no matter how hard I try I can't get evolution to recover my not-yet-sent composed messages anymore. Here's the steps I tried to reproduce:

- compose a fake email, don't send it
- pkill evolution in a terminal
- restart evolution
- the imap password prompt pops up but it doesn't recover my in-progress email composition :(
- I also tried these steps by triggering a crash I can reproduce reliably (filing another bug on that) but it didn't seem to matter.

When I'm actually writing an email, not just a fake test one, and evolution crashes, it usually recovers it! Maybe it knows I'm faking... :)

Comment 2 Matthew Barnes 2010-05-25 20:54:50 UTC
Yeah, this is something I've been meaning to address upstream.  We either need to put these dialogs in a central queue so they only appear one at a time, or (preferably) start using GtkInfoBars for things like message recovery.  (I imagine password prompts will always have to remain in a pop-up window.)

Not really sure how to address this for RHEL, since we're pretty much limited to small, uninvasive patches.  This would be better tackled in Fedora first, then picked up for RHEL in a future desktop rebase.

To help reproduce this: paritally composed messages are saved to files of the form


but the autosave runs on a timeout loop, so it may be that you need to type something and then wait for the autosave file to show up before killing Evolution.

Comment 3 RHEL Product and Program Management 2010-06-07 16:04:05 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for

Comment 4 Matthew Barnes 2010-06-07 17:23:20 UTC
Devel NACK.  See comment #2.

Need to solve this upstream first and then pick it up in a rebase.

Comment 5 RHEL Product and Program Management 2010-06-07 17:25:23 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.