Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595814 - Need to fix udev rule to match the current reality
Summary: Need to fix udev rule to match the current reality
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: ifd-egate
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bob Relyea
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 636773 (view as bug list)
Depends On:
Blocks: F15Blocker, F15FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2010-05-25 16:52 UTC by Valdis Kletnieks
Modified: 2010-12-06 18:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-06 18:35:15 UTC


Attachments (Terms of Use)
Patch to fix udev ruleset (deleted)
2010-05-25 16:52 UTC, Valdis Kletnieks
no flags Details

Description Valdis Kletnieks 2010-05-25 16:52:37 UTC
Created attachment 416452 [details]
Patch to fix udev ruleset

Description of problem:
85-pcscd_egate.rules still has SYSFS{} which needs to be converted to ATTR{}

Version-Release number of selected component (if applicable):
ifd-egate-0.05-22.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Bug Zapper 2010-07-30 11:42:23 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Adam Jackson 2010-12-01 16:29:24 UTC
*** Bug 636773 has been marked as a duplicate of this bug. ***

Comment 3 Matt Domsch 2010-12-04 03:58:45 UTC
This is marked as an F15 blocker, however, the package is orphaned in pkgdb, and has no F14 branch.  Is the package still needed?

Comment 4 Valdis Kletnieks 2010-12-04 15:23:28 UTC
Depends how you define "needed":

# rpm -q --provides ifd-egate
libifd_egate.so()(64bit)  
pcsc-ifd-handler  
ifd-egate = 0.05-22
ifd-egate(x86-64) = 0.05-22
# rpm -q --whatrequires pcsc-ifd-handler
pcsc-lite-1.6.4-1.fc15.x86_64

And I *do* need pcsc-lite to support an application that uses an Alladin e-Token. So as it currently stands, ifd-egate gets installed because of the requires.  But I'd not be heartbroken if pcsc-lite lost its dependency, as I don't need ifd-egate directly.

Comment 5 Bob Relyea 2010-12-06 18:35:15 UTC
ifd-egate is not requred for pcsc-lite. pcsc-ifd-handler is a pseudo provides. pcsc-lite needs at least one. The proper one to use is ccid.

# rpm -q --provides ccid
config(ccid) = 1.4.0-1.fc14
libccid.so.0()(64bit)  
libccidtwin.so.0()(64bit)  
pcsc-ifd-handler  
ccid = 1.4.0-1.fc14
ccid(x86-64) = 1.4.0-1.fc14

upstream for ifd-egate is long dead. The ifd-egate hardware has not been produced in years. This bug can be closed.


Note You need to log in before you can comment on or make changes to this bug.