Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595765 - KVM VM panicked
Summary: KVM VM panicked
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.5
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Virtualization Maintenance
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-25 14:59 UTC by Steve Reichard
Modified: 2012-07-16 22:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-16 22:22:15 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Steve Reichard 2010-05-25 14:59:53 UTC
Description of problem:

In our environment we have a RHEL 5.5 host run a RHEL 5.5 VM.   The VM is mostly used to run RHN Satellite 5.3.

At the time of the panic, no one was actively performing actions on either the system or VM, it happened over the weekend.  People may have been logged in but idle.

The issue was noticed by not being able to log into the VM. Using the virt-viewer, this stack trace, http://irish.lab.bos.redhat.com/pub/bz_data/<BZ######>/virt-viewer_sat-vm_crash.png , was seen on the console.

On the host a virsh dump was performed and the memory file is in 
http://irish.lab.bos.redhat.com/pub/bz_data/<BZ######>/sat_crash.  The two kernels that were on the VM are also in this directory.  I assume it was using the latest,but not sure if the sytstem had been restarted since the last update.


Version-Release number of selected component (if applicable):

Linux sat-vm.cloud.lab.eng.bos.redhat.com 2.6.18-194.3.1.el5 #1 SMP Sun May 2 04:17:42 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux



How reproducible:

At this point, this has not reproduced.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 David Howells 2010-05-25 16:33:03 UTC
(In reply to comment #0)
> The issue was noticed by not being able to log into the VM. Using the
> virt-viewer, this stack trace,
> http://irish.lab.bos.redhat.com/pub/bz_data/<BZ######>/virt-viewer_sat-vm_crash.png
> , was seen on the console.

This BZ doesn't seem to be represented there.

There is one for bug 595765 which shows what you might be talking about.

Is there any way you can retrieve the panic message or at least the EIP value?  It's impossible to say for certain which function actually panicked without that since there's certainly at least one obsolete function pointer on the stack.

(Note that the code in RHEL-5 is prior to my implementation of COW credentials.)


Note You need to log in before you can comment on or make changes to this bug.