Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595625 - OEMDRV labelled driver not loaded
Summary: OEMDRV labelled driver not loaded
Keywords:
Status: CLOSED DUPLICATE of bug 593941
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: driver-update-program
Version: 6.0
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Jon Masters
QA Contact: Qian Cai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-25 08:30 UTC by Qian Cai
Modified: 2010-08-20 20:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-25 08:39:21 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Qian Cai 2010-05-25 08:30:45 UTC
Description of problem:
When loading a DUD with label OEMDRV, it looks like not mounted.

INFO: trying to mount CD device /dev/sr0 on /mnt/stage2
INFO: drive status is CDS_DISC_OK
<Ctrl-Z>
bash-4.1# busybox ls /mnt/stage2
bash-4.1# mount /dev/sr0 /mnt/stage2/
mount: block device /dev/sr0 is write-protected, mounted read-only

Version-Release number of selected component (if applicable):
RHEL6.0-20100524.n.0
anaconda-13.21.45-1.el6

How reproducible:
always

Steps to Reproduce:
1. create a DUD with label OEMDRV
2. start the installer
  
Actual results:
DUD was not mounted, and driver was not loaded.

Expected results:
DUD was mounted, and driver was loaded.

Comment 1 Martin Sivák 2010-05-25 08:39:21 UTC
The DD is mounted only temporarily and the content is copied to /tmp/DD-number and then extracted to /tmp/DD/lib/modules... Modprobe didn't pick the modules up because of the bug mentioned in #593941. And that bug wasn't fixed until anaconda-13.21.46-1.el6.

*** This bug has been marked as a duplicate of bug 593941 ***


Note You need to log in before you can comment on or make changes to this bug.