Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595600 - Segfault on start
Summary: Segfault on start
Keywords:
Status: CLOSED DUPLICATE of bug 592786
Alias: None
Product: Fedora
Classification: Fedora
Component: gpointing-device-settings
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gianluca Sforna
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-25 06:49 UTC by Simon Goodall
Modified: 2010-05-25 15:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-25 15:13:47 UTC


Attachments (Terms of Use)

Description Simon Goodall 2010-05-25 06:49:14 UTC
Description of problem: 
I used gpointing-device-setting to disable the tap on my touchpad (Asus eeepc 901). However, when I try to start the application to re-enable it, I now get a segfault.

Starting program: /usr/bin/gpointing-device-settings 
[Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault.
0x003cad83 in set_tapping_time_from_preference (ui=0x809e228 [GpdsTouchpadUI], 
    error=0xbffff08c) at gpds-touchpad-ui.c:969
969	        value = values[0];


#0  0x003cad83 in set_tapping_time_from_preference (ui=
    0x809e228 [GpdsTouchpadUI], error=0xbffff08c) at gpds-touchpad-ui.c:969
#1  setup_current_values (ui=0x809e228 [GpdsTouchpadUI], error=0xbffff08c)
    at gpds-touchpad-ui.c:1005
#2  build (ui=0x809e228 [GpdsTouchpadUI], error=0xbffff08c)
    at gpds-touchpad-ui.c:1059
#3  0x00c954ed in gpds_ui_build (ui=0x809e228 [GpdsTouchpadUI], error=
    0xbffff08c) at gpds-ui.c:221
#4  0x080493a8 in append_ui (icon_view=0x80a3020 [GtkIconView], notebook=
    0x80978f0 [GtkNotebook], ui=0x809e228 [GpdsTouchpadUI])
    at gpointing-device-settings.c:106
#5  0x0804996d in append_uis (argc=1, argv=0xbffff1d4)
    at gpointing-device-settings.c:168
#6  main (argc=1, argv=0xbffff1d4) at gpointing-device-settings.c:257



Version-Release number of selected component (if applicable):

gpointing-device-settings-1.5.1-1.fc13.i686


How reproducible:


Steps to Reproduce:
1. Start application.
2. Segfaults
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Gianluca Sforna 2010-05-25 08:33:05 UTC
Looks like a duplicate of bug 592786.

Can you please test if 
http://koji.fedoraproject.org/koji/buildinfo?buildID=173761

fixes the issue and let me know so I can push the update?

Comment 2 Simon Goodall 2010-05-25 11:23:08 UTC
It works for me.

Comment 3 Gianluca Sforna 2010-05-25 15:13:47 UTC
Great. I'm preparing the update.

*** This bug has been marked as a duplicate of bug 592786 ***


Note You need to log in before you can comment on or make changes to this bug.