Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595585 - pigment freezes on intel video card
Summary: pigment freezes on intel video card
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: pigment-python
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-25 05:36 UTC by Graeme Gillies
Modified: 2010-09-26 23:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-26 23:11:44 UTC


Attachments (Terms of Use)

Description Graeme Gillies 2010-05-25 05:36:38 UTC
Description of problem:
Hi, I recently upgraded to fedora 13 and noticed that any pigment application that doesn't run fullscreen on my laptop will freeze, including the pigment examples. Tried to reproduce on another machine with a different video card and couldn't so I assume the problem is against intel cards only.

Version-Release number of selected component (if applicable):
pigment-python-0.3.12-2.fc12.i686
xorg-x11-drv-intel-2.11.0-4.fc13.i686

How reproducible:
Very easy to reproduce on an intel system

Steps to Reproduce:
1. run from terminal
cd /usr/share/doc/pigment-python-0.3.12
python examples/image.py

or

1. run from terminal
cd /usr/share/doc/pigment-python-0.3.12
python examples/sphere.py
  
Actual results:
You get a black window that has titles and borders, but is essentually frozen (no picture, and clicking on X on window eventually gives "This window is not responding")

Expected results:
First example should give you the fluendo logo on a black background, second example should give a sphere in the middle of the black window. In both examples clicking on X in top right should close window.

Additional info:
lspci output
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07) (prog-if 00 [VGA controller])
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

Comment 1 Graeme Gillies 2010-09-26 23:11:44 UTC
It seems that this now appears to be working. Not sure which update fixed it but, but it works with

pigment-python-0.3.12-2.fc13.i686
pigment-0.3.17-3.fc13.i686
xorg-x11-drv-intel-2.11.0-5.fc13.i686


Note You need to log in before you can comment on or make changes to this bug.