Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595550 - pkgconfig 0.24 breaks mono compiler by escaping its output
Summary: pkgconfig 0.24 breaks mono compiler by escaping its output
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pkgconfig
Version: rawhide
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-24 23:08 UTC by Christian Krause
Modified: 2010-05-27 00:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-27 00:25:21 UTC


Attachments (Terms of Use)

Description Christian Krause 2010-05-24 23:08:10 UTC
Description of problem:

pkgconfig 0.24 breaks the mono compiler when using the -pkg parameter:

----------------------
       -pkg:package1[,packageN]
              Reference assemblies for the given packages.

              The  compiler  will invoke pkg-config --libs on the set of pack-
              ages specified on the  command  line  to  obtain  libraries  and
              directories to compile the code.
----------------------

Calling the mono compiler with this parameter seems to be the default when compiling mono packages and so the problem is quite critical.


Version-Release number of selected component (if applicable):
1:0.24-2.fc14


How reproducible:
100%

Steps to Reproduce:
1. yum install gtk-sharp2-devel
2. yum install mono-core
3. echo "class test { static void Main() {}}" > test.cs
4. gmcs -pkg:gtk-sharp-2.0 test.cs
5. pkg-config --libs gtk-sharp-2.0


Actual results:
for 4.: error CS2007: Unrecognized command-line option: `-r\:/usr/lib/mono/gtk-sharp-2.0/pango-sharp.dll'

for 5.:
-r\:/usr/lib/mono/gtk-sharp-2.0/pango-sharp.dll -r\:/usr/lib/mono/gtk-sharp-2.0/atk-sharp.dll -r\:/usr/lib/mono/gtk-sharp-2.0/gdk-sharp.dll -r\:/usr/lib/mono/gtk-sharp-2.0/gtk-sharp.dll -r\:/usr/lib/mono/gtk-sharp-2.0/glib-sharp.dll

Expected results:
for 4.: no error message
for 5.:
-r:/usr/lib/mono/gtk-sharp-2.0/pango-sharp.dll -r:/usr/lib/mono/gtk-sharp-2.0/atk-sharp.dll -r:/usr/lib/mono/gtk-sharp-2.0/gdk-sharp.dll -r:/usr/lib/mono/gtk-sharp-2.0/gtk-sharp.dll -r:/usr/lib/mono/gtk-sharp-2.0/glib-sharp.dll

Please note the additional backslash before the ":" in the output of pkgconfig 0.24.


Note You need to log in before you can comment on or make changes to this bug.