Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595549 - iscsid/uIP are not synchronized when logging into an iSCSI target
Summary: iscsid/uIP are not synchronized when logging into an iSCSI target
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iscsi-initiator-utils
Version: 5.6
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Mike Christie
QA Contact: Gris Ge
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-24 23:06 UTC by Benjamin Li
Modified: 2011-07-21 08:25 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-21 08:25:21 UTC
Target Upstream Version:


Attachments (Terms of Use)
uIP-0.5.15 (deleted)
2010-05-24 23:07 UTC, Benjamin Li
no flags Details
iscsid patch to synchronize with uIP during login (deleted)
2010-05-24 23:08 UTC, Benjamin Li
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1033 normal SHIPPED_LIVE iscsi-initiator-utils bug fix and enhancement update 2011-07-20 15:44:03 UTC

Description Benjamin Li 2010-05-24 23:06:12 UTC
Description of problem:

Before there was no synchronization between iscsid during login and when the brcm_iscsiuio network stack was ready.  Because of this, if the brcm_iscsiuio stack is slow and may take longer then the iSCSI login timeout or may return a login error


Version-Release number of selected component (if applicable):
iscsi-initiator-utils-6.2.0.871-0.16.el5/uIP-0.5.7


Steps to Reproduce:
1.  Try to login to a iSCSI target via a Broadcom offload device, one will notice that login will occasionally fail.  This is true especially when the uIP network stack takes a while to initialize (ie. using a DHCP to obtain an IP address)

Comment 1 Benjamin Li 2010-05-24 23:07:38 UTC
Created attachment 416236 [details]
uIP-0.5.15

Current, brcm_iscsiuio version which includes the fix to syncronized with iscsid

Comment 2 Benjamin Li 2010-05-24 23:08:49 UTC
Created attachment 416237 [details]
iscsid patch to synchronize with uIP during login

Comment 3 Mike Christie 2010-07-11 10:27:51 UTC
This is fixed in iscsi-initiator-utils-6.2.0.871-0.18.el5. You can grab it here:
http://people.redhat.com/mchristi/iscsi/rhel5.6/iscsi-initiator-utils/

Comment 5 RHEL Product and Program Management 2010-08-09 18:09:01 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 9 Gris Ge 2011-06-02 08:07:13 UTC
Benjamin,
We don't have Broadcom iSCSI TOE in Red Hat.
Can  you help us for testing the patched rpm?
http://people.redhat.com/mchristi/iscsi/rhel5.6/iscsi-initiator-utils/

Thanks.

Comment 11 Gris Ge 2011-06-24 02:21:35 UTC
No hardware, Sanity Only.

Comment 12 errata-xmlrpc 2011-07-21 08:25:21 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1033.html


Note You need to log in before you can comment on or make changes to this bug.