Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595523 - VG reconfiguration will cause mirror creation to fail
Summary: VG reconfiguration will cause mirror creation to fail
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2
Version: 6.0
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Milan Broz
QA Contact: Corey Marthaler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-24 21:15 UTC by Corey Marthaler
Modified: 2013-03-01 04:09 UTC (History)
10 users (show)

Fixed In Version: lvm2-2.02.69-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-10 21:07:53 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Corey Marthaler 2010-05-24 21:15:28 UTC
Description of problem:
# created 300M PVs
  PV /dev/sdd1   VG mirror_sanity   lvm2 [296.00 MiB / 296.00 MiB free]
  PV /dev/sde1   VG mirror_sanity   lvm2 [296.00 MiB / 296.00 MiB free]
  PV /dev/sdf1   VG mirror_sanity   lvm2 [296.00 MiB / 296.00 MiB free]
  PV /dev/sdg1   VG mirror_sanity   lvm2 [296.00 MiB / 296.00 MiB free]
  PV /dev/sdh1   VG mirror_sanity   lvm2 [296.00 MiB / 296.00 MiB free]

# attempt to create a 200M contiguous mirror
SCENARIO - [contiguous_opt_check]
Sanity check for the contiguous allocation option
Recreating PVs/VG with smaller sizes
Attempting mirror creation with enough contiguous space
taft-01: lvcreate -m 1 -n contig_with -C y -L 200M mirror_sanity
  Error locking on node taft-01: Volume group for uuid not found: KJPlcA2hkJwABF44LX6xJe7wKWPJ10R49M229Orhd8FLfWHZa992lRotZDczNdml
  Aborting. Failed to activate mirror log.
  Failed to initialise mirror log.
create should have worked, should be enough allocable space

# mirror log gets created but nothing else
[root@taft-02 ~]# dmsetup ls
mirror_sanity-contig_with_mlog  (253, 3)
vg_taft02-lv_home       (253, 2)
vg_taft02-lv_swap       (253, 1)
vg_taft02-lv_root       (253, 0)

Version-Release number of selected component (if applicable):
2.6.32-25.el6.x86_64

lvm2-2.02.65-1.el6    BUILT: Tue May 18 04:46:06 CDT 2010
lvm2-libs-2.02.65-1.el6    BUILT: Tue May 18 04:46:06 CDT 2010
lvm2-cluster-2.02.65-1.el6    BUILT: Tue May 18 04:46:06 CDT 2010
device-mapper-1.02.48-1.el6    BUILT: Tue May 18 04:46:06 CDT 2010
device-mapper-libs-1.02.48-1.el6    BUILT: Tue May 18 04:46:06 CDT 2010
device-mapper-event-1.02.48-1.el6    BUILT: Tue May 18 04:46:06 CDT 2010
device-mapper-event-libs-1.02.48-1.el6    BUILT: Tue May 18 04:46:06 CDT 2010
cmirror-2.02.65-1.el6    BUILT: Wed May 19 11:19:57 CDT 2010

How reproducible:
Everytime

Comment 1 Alasdair Kergon 2010-05-24 22:16:49 UTC
It's not a failure due to lack of space.  It's a cluster locking or cache (or perhaps udev) failure...   We need to find out why taft-01 could not find the VG.

Comment 2 Alasdair Kergon 2010-05-24 22:59:24 UTC
Bumping severity and priority on the assumption this is an activation problem not an allocation problem.  Milan, you're good with bugs like these:)

Comment 3 Corey Marthaler 2010-05-24 23:02:49 UTC
I was able to hit this with another unrelated testcase that also reconfigures the VG before the mirror creation.

SCENARIO - [create_mirror_on_1Kextent_vg]
Create a mirror on a VG with an extent size of only 1K
Recreating PVs/VG with smaller (1K) extent size
taft-01: vgcreate -s 1K mirror_sanity /dev/sdd1 /dev/sde1 /dev/sdf1 /dev/sdg1 /dev/sdh1
taft-01: lvcreate -m 1 -n mirror_on_1Kextent_vg -L 20M mirror_sanity
  Error locking on node taft-01: Volume group for uuid not found: t01HsshA4Aw17nPTic02ItnekGvm0D7o0F7mOK6EXCau3cQf74dKBZGxVPibhdGg
  Aborting. Failed to activate mirror log.
  Failed to initialise mirror log.
couldn't create mirror on 1K extent VG

Comment 4 Milan Broz 2010-07-01 21:10:51 UTC
The same problem as bug #608879.

Comment 5 Corey Marthaler 2010-07-02 16:36:23 UTC
These VG configuration test cases now work...

SCENARIO - [contiguous_opt_check]                            
Sanity check for the contiguous allocation option            
Recreating PVs/VG with smaller sizes                         
Attempting mirror creation without enough contiguous space
grant-01: lvcreate -m 1 -n contig_without -C y -L 400M mirror_sanity
  Insufficient suitable contiguous allocatable extents for logical volume contig_without: 100 more required
Attempting mirror creation with enough contiguous space
grant-01: lvcreate -m 1 -n contig_with -C y -L 200M mirror_sanity
Deactivating mirror contig_with... and removing
Restoring VG to default extent size

SCENARIO - [create_mirror_on_1Kextent_vg]
Create a mirror on a VG with an extent size of only 1K
Recreating PVs/VG with smaller (1K) extent size
grant-01: vgcreate -s 1K mirror_sanity /dev/sdb1 /dev/sdb2 /dev/sdb3 /dev/sdc1 /dev/sdc2 /dev/sdc3
grant-01: lvcreate -m 1 -n mirror_on_1Kextent_vg -L 20M mirror_sanity
Deactivating mirror mirror_on_1Kextent_vg... and removing
Restoring VG to default extent size

Fix verified in the follow build:
lvm2-2.02.69-2.el6    BUILT: Fri Jul  2 07:26:01 CDT 2010
lvm2-libs-2.02.69-2.el6    BUILT: Fri Jul  2 07:26:01 CDT 2010
lvm2-cluster-2.02.69-2.el6    BUILT: Fri Jul  2 07:26:01 CDT 2010
device-mapper-1.02.51-2.el6    BUILT: Fri Jul  2 07:26:01 CDT 2010
device-mapper-libs-1.02.51-2.el6    BUILT: Fri Jul  2 07:26:01 CDT 2010
device-mapper-event-1.02.51-2.el6    BUILT: Fri Jul  2 07:26:01 CDT 2010
device-mapper-event-libs-1.02.51-2.el6    BUILT: Fri Jul  2 07:26:01 CDT 2010
cmirror-2.02.69-2.el6    BUILT: Fri Jul  2 07:26:01 CDT 2010

Comment 6 releng-rhel@redhat.com 2010-11-10 21:07:53 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.