Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595522 - udev should not restrict /dev/disk/by-path entries for all "virtual" devices
Summary: udev should not restrict /dev/disk/by-path entries for all "virtual" devices
Keywords:
Status: CLOSED DUPLICATE of bug 601248
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: udev
Version: 6.0
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Harald Hoyer
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
: 593744 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-24 21:13 UTC by Robert Love
Modified: 2010-06-08 13:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-08 13:26:28 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Robert Love 2010-05-24 21:13:48 UTC
Description of problem:
A restriction was added to the udev rule which generates by-path entries sometime between F11 and F12.

The problem is that udev restricts "virtual" devices from having a by-path entry. However, this new restriction does not take networked storage devices running on a VLAN under consideration. fcoe connections are always on VLANs and will always be on "virtual" network devices.

Version-Release number of selected component (if applicable):

How reproducible:
Always.

Steps to Reproduce:

1. Use fcoe-utils to connect to a FC SAN using a NIC.
    * LUNs will be enumerated and by-id and by-uuid entries will be created.
    * No by-path entries will be created
  
Actual results:


Expected results:


Additional info:

The rule is in: /lib/udev/rules.d/60-persistent-storage.rules

ENV{DEVTYPE}=="disk", ENV{ID_PATH}=="", DEVPATH!="*/virtual/*", IMPORT{program}="path_id %p"

Either the "virtual" condition needs to be removed or made more elegant.

Comment 2 RHEL Product and Program Management 2010-06-02 14:45:59 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Phil Knirsch 2010-06-04 15:01:37 UTC
Is there a way to detect if a virtual device is a FCOE device? If so, then it should be fairly easy to do.

Thanks & regards, Phil

Comment 4 Robert Love 2010-06-04 18:01:11 UTC
I think the problem is slightly broader than the initial reporting. Any networked storage on a VLAN would have this issue. For example, if iSCSI were run on a VLAN there would be no by-path entry.

Sorry to answer your question with another question, but how do I know which path udev is using for its rules in the sysfs tree? With that info I can tell you what the FCoE path looks like.

Comment 5 Harald Hoyer 2010-06-08 10:43:38 UTC
*** Bug 593744 has been marked as a duplicate of this bug. ***

Comment 6 Harald Hoyer 2010-06-08 13:26:28 UTC

*** This bug has been marked as a duplicate of bug 601248 ***


Note You need to log in before you can comment on or make changes to this bug.