Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595494 - RHEL6.0-20100512.0-Server appears to break console output
Summary: RHEL6.0-20100512.0-Server appears to break console output
Keywords:
Status: CLOSED DUPLICATE of bug 590851
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-24 19:39 UTC by Corey Marthaler
Modified: 2010-05-25 14:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-25 14:17:45 UTC
Target Upstream Version:


Attachments (Terms of Use)
sosreport from affected system (deleted)
2010-05-24 20:13 UTC, Nate Straz
no flags Details

Description Corey Marthaler 2010-05-24 19:39:37 UTC
Description of problem:
After installing RHEL6.0-20100512.0-Server on 4 test systems, their consoles no longer work properly.

Comment 1 Nate Straz 2010-05-24 20:13:59 UTC
Created attachment 416217 [details]
sosreport from affected system

I'm able to read from ttyS0 if I cat it and type on the serial console, kernel debug output makes it to the serial console, but agetty seems stuck in an ioctl.  Other test systems work fine.

[root@taft-01 ~]# strace -p `pidof agetty`
Process 2237 attached - interrupt to quit
fstat(3, {st_mode=S_IFREG|0644, st_size=80, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f87b5a34000
read(3, "Red Hat Enterprise Linux Server "..., 4096) = 80
fstat(1, {st_mode=S_IFCHR|0600, st_rdev=makedev(4, 64), ...}) = 0
ioctl(1, SNDCTL_TMR_TIMEBASE or TCGETS, {B115200 -opost -isig -icanon -echo ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f87b5a33000
write(1, "Red Hat Enterprise Linux Server "..., 60) = 60
write(1, "Kernel 2.6.32-25.el6.x86_64 on a"..., 41) = 41
write(1, "\n", 1)                       = 1
read(3, "", 4096)                       = 0
ioctl(0, SNDCTL_TMR_STOP or TCSETSW

sysrq
agetty        S ffff88021fc24500     0  2354      1 0x00000080
 ffff8802134dfb18 0000000000000082 ffff8802134dfae0 ffff8802134dfadc
 ffff8802134dfaa8 ffff88021fc24500 ffff880028256180 000000010067355c
 ffff880214922638 ffff8802134dffd8 000000000000fd38 ffff880214922638
Call Trace:
 [<ffffffff814c9235>] schedule_timeout+0x225/0x2f0
 [<ffffffff811f8121>] ? avc_has_perm+0x71/0x90
 [<ffffffff812f1d40>] tty_wait_until_sent+0xb0/0x100
 [<ffffffff8108cbb0>] ? autoremove_wake_function+0x0/0x40
 [<ffffffff812f2292>] set_termios+0x502/0x530
 [<ffffffff811f7eeb>] ? avc_has_perm_noaudit+0x2cb/0x490
 [<ffffffff812f270a>] tty_mode_ioctl+0x34a/0x480
 [<ffffffff814c987e>] ? mutex_lock+0x1e/0x50
 [<ffffffff8131aefa>] ? uart_ioctl+0xea/0x330
 [<ffffffff812f2879>] n_tty_ioctl_helper+0x39/0x1c0
 [<ffffffff8115f557>] ? nameidata_to_filp+0x57/0x70
 [<ffffffff812eee43>] n_tty_ioctl+0x23/0xf0
 [<ffffffff812ec41b>] tty_ioctl+0xdb/0x930
 [<ffffffff81174772>] vfs_ioctl+0x22/0xa0
 [<ffffffff81174914>] do_vfs_ioctl+0x84/0x580
 [<ffffffff81174e91>] sys_ioctl+0x81/0xa0
 [<ffffffff81013172>] system_call_fastpath+0x16/0x1b

Comment 2 John Villalovos 2010-05-25 01:33:14 UTC
This might be a duplicate of Bug 568418

Comment 3 John Villalovos 2010-05-25 01:46:22 UTC
Though bug 568418 may have been fixed in the kernel you tried.

If the hang you see occurs only after you enter a username, then it is likely a duplicate of Bug 590851

Comment 4 John Villalovos 2010-05-25 01:54:57 UTC
Okay RHEL6.0-20100512.0-Server has the 2.6.32-25 kernel which already has the fix for Bug 568418.

So this leaves Bug 590851 as the likely culprit.

Can you try the test kernel in Brew and see if it fixes your problem?
https://brewweb.devel.redhat.com/taskinfo?taskID=2468204

Comment 5 Nate Straz 2010-05-25 13:29:41 UTC
I booted with 2.6.32-28.el6bz590851_v1.x86_64 and I can now use the serial console again.

Comment 6 John Villalovos 2010-05-25 14:17:45 UTC

*** This bug has been marked as a duplicate of bug 590851 ***


Note You need to log in before you can comment on or make changes to this bug.