Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595476 - dmesg shows BUG warning at drivers/base/core.c:101/device_release()
Summary: dmesg shows BUG warning at drivers/base/core.c:101/device_release()
Keywords:
Status: CLOSED DUPLICATE of bug 592846
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.5
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: John Feeney
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-24 18:22 UTC by D. Marlin
Modified: 2013-01-10 07:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-02 19:12:29 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description D. Marlin 2010-05-24 18:22:49 UTC
Description of problem:

After restart on a clean install the following BUG is found in dmesg on DELL-PEM610-02:

--------------
Linux version 2.6.18-194.el5 (mockbuild@x86-005.build.bos.redhat.com) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-48)) #1 SMP Tue Mar 16 21:52:39 EDT 2010
Command line: ro root=/dev/VolGroup00/LogVol00 console=ttyS0,115200
      :
ACPI: Power Button (FF) [PWRF]
ACPI: Mapper loaded
dell-wmi: No known WMI GUID found
ACPI Exception (evregion-0424): AE_SUPPORT, Returned by Handler for [DataTable] [20060707]
ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PMI0._GHL] (Node ffff8101b54fd830), AE_SUPPORT
ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PMI0._PMC] (Node ffff8101b54fd870), AE_SUPPORT
ACPI Exception (power_meter-0759): AE_SUPPORT, Evaluating _PMC [20060707]
Device 'power_meter0' does not have a release() function, it is broken and must be fixed.
BUG: warning at drivers/base/core.c:101/device_release() (Not tainted)

Call Trace:
 [<ffffffff801519ef>] kobject_cleanup+0x53/0x7e
 [<ffffffff80151a1a>] kobject_release+0x0/0x9
 [<ffffffff80035748>] kref_put+0x6f/0x7a
 [<ffffffff882770ed>] :power_meter:acpi_power_meter_add+0x158/0x16f
 [<ffffffff801a115e>] acpi_bus_driver_init+0x30/0x57
 [<ffffffff801a237c>] acpi_bus_register_driver+0x95/0xd4
 [<ffffffff88184032>] :power_meter:acpi_power_meter_init+0x25/0x34
 [<ffffffff800a7fe0>] sys_init_module+0xaf/0x1f2
 [<ffffffff8005e116>] system_call+0x7e/0x83
--------------


Version-Release number of selected component (if applicable):
  kernel-2.6.18-194.el5

How reproducible:
  always

Steps to Reproduce:
1.  provision the system
2.  reboot
3.  check dmesg
  
Actual results:
  BUG and call trace in dmesg

Expected results:
  no BUG

Additional info:
  The following RHTS job exhibits the issue:
    http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=159460

Comment 1 Matthew Garrett 2010-06-02 19:12:29 UTC

*** This bug has been marked as a duplicate of bug 592846 ***


Note You need to log in before you can comment on or make changes to this bug.