Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595390 - Feature Request: coretemp: support for Xeon 3300
Summary: Feature Request: coretemp: support for Xeon 3300
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.5
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks: 588115
TreeView+ depends on / blocked
 
Reported: 2010-05-24 14:08 UTC by David Kovalsky
Modified: 2014-03-31 23:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-16 14:45:58 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description David Kovalsky 2010-05-24 14:08:17 UTC
Description of problem:
Xeon 3330, but it's not supported under current kernel/lm_sensors

syslog shows: 
kernel: w83627ehf: Found W83627DHG chip at 0x290  
kernel: coretemp: Unknown CPU model 17 

Version-Release number of selected component (if applicable):
kernel-2.6.18-194.el5
lm_sensors-2.10.7-9.el5

So I've tried the kmod-coretemp from elrepo with updated lmsensors from the
same repo:

http://elrepo.org/linux/elrepo/el5/x86_64/RPMS/kmod-coretemp-xen-1.1-6.el5.elrepo.x86_64.rpm

http://elrepo.org/linux/elrepo/el5/x86_64/RPMS/lm_sensors-2.10.8-2.el5.elrepo.x86_64.rpm


Works like charm. lm-sensors output:
coretemp-isa-0000
Adapter: ISA adapter
Core 0:      +38°C  (high =  +100°C)                   

coretemp-isa-0001
Adapter: ISA adapter
Core 1:      +25°C  (high =  +100°C)                   

coretemp-isa-0002
Adapter: ISA adapter
Core 2:      +34°C  (high =  +100°C)                   

coretemp-isa-0003
Adapter: ISA adapter
Core 3:      +41°C  (high =  +100°C)

Comment 1 Gerrit Slomma 2010-06-12 13:44:50 UTC
Same problem here.
I had backported i5k_amb and coretemp kernel-modules as well as a backported lm_sensors-3 from Fedora 12 for Kernel 2.6.18-164 that worked without problems:

# sensors|grep Core
Core 7: +58.0°C (high = +74.0°C, crit = +100.0°C)
Core 6: +65.0°C (high = +74.0°C, crit = +100.0°C)
Core 5: +49.0°C (high = +74.0°C, crit = +100.0°C)
Core 4: +57.0°C (high = +74.0°C, crit = +100.0°C)
Core 3: +51.0°C (high = +74.0°C, crit = +100.0°C)
Core 2: +55.0°C (high = +74.0°C, crit = +100.0°C)
Core 1: +57.0°C (high = +74.0°C, crit = +100.0°C)
Core 0: +63.0°C (high = +74.0°C, crit = +100.0°C)

# sensors|grep DIMM
Ch. 0 DIMM 0: +61.0°C (low = +74.5°C, high = +124.0°C)
Ch. 1 DIMM 0: +57.0°C (low = +74.5°C, high = +124.0°C)

sensors-detect now works:

(...)
Intel Core family thermal sensor...                         Success!
    (driver `coretemp')
Intel AMB FB-DIMM thermal sensor...                         Success!
    (driver `to-be-written')
(...)
Driver `w83793' (should be inserted):
  Detects correctly:
  * Bus `SMBus I801 adapter at 1100'
    Busdriver `i2c-i801', I2C address 0x2f (and 0x4b 0x4f)
    Chip `Winbond W83793R/G' (confidence: 8)

Driver `coretemp' (should be inserted):
  Detects correctly:
  * Chip `Intel Core family thermal sensor' (confidence: 9)

Driver `to-be-written' (should be inserted):
  Detects correctly:
  * Chip `Intel AMB FB-DIMM thermal sensor' (confidence: 9)
(...)

At least coretemp should be loaded:

# tail -3 /etc/sysconfig/lm_sensors
MODULE_0=i2c-i801
MODULE_1=w83793
MODULE_2=coretemp

But fails:

# dmesg
coretemp: Unknown CPU model 17
coretemp: Unknown CPU model 17
coretemp: Unknown CPU model 17
coretemp: Unknown CPU model 17
coretemp: Unknown CPU model 17
coretemp: Unknown CPU model 17
coretemp: Unknown CPU model 17
coretemp: Unknown CPU model 17

i5k_amb is not present either

# lsmod|grep coretemp
# lsmod|grep i5k_amb

# find /lib/modules -name "i5k_amb.ko";find /lib/modules -name "coretemp.ko"
/lib/modules/2.6.18-164.11.1.el5/weak-updates/i5k_amb.ko
/lib/modules/2.6.18-155.el5/weak-updates/i5k_amb.ko
/lib/modules/2.6.18-164.el5/weak-updates/i5k_amb.ko
/lib/modules/2.6.18-194.el5/kernel/drivers/hwmon/i5k_amb.ko
/lib/modules/2.6.18-128.1.6.el5/extra/i5k_amb.ko
/lib/modules/2.6.18-164.11.1.el5/weak-updates/coretemp.ko
/lib/modules/2.6.18-155.el5/weak-updates/coretemp.ko
/lib/modules/2.6.18-164.el5/weak-updates/coretemp.ko
/lib/modules/2.6.18-194.el5/kernel/drivers/hwmon/coretemp.ko
/lib/modules/2.6.18-128.1.6.el5/extra/coretemp.ko

Here my backported versus the one from the release

# modinfo /lib/modules/2.6.18-164.el5/weak-updates/i5k_amb.ko
filename:       /lib/modules/2.6.18-164.el5/weak-updates/i5k_amb.ko
license:        GPL
description:    Intel 5000 chipset FB-DIMM AMB temperature sensor
author:         Darrick J. Wong <djwong@us.ibm.com>
srcversion:     F0146D28050A139EA3F5217
depends:        hwmon
vermagic:       2.6.18-128.1.6.el5 SMP mod_unload gcc-4.1

# modinfo /lib/modules/2.6.18-194.el5/kernel/drivers/hwmon/i5k_amb.ko
filename:       /lib/modules/2.6.18-194.el5/kernel/drivers/hwmon/i5k_amb.ko
license:        GPL
description:    Intel 5000 chipset FB-DIMM AMB temperature sensor
author:         Darrick J. Wong <djwong@us.ibm.com>
srcversion:     4BD7A9BD6128E807E21424B
depends:        hwmon
vermagic:       2.6.18-194.el5 SMP mod_unload gcc-4.1
module_sig:     883f3504bb644ffc596239a507de7fd112fd009e2081a1225fc9e661165b83fa8e7244b9338a63409e34e14f61f5541119674625715379e30b4677fda

# modinfo /lib/modules/2.6.18-164.el5/weak-updates/coretemp.ko
filename:       /lib/modules/2.6.18-164.el5/weak-updates/coretemp.ko
license:        GPL
description:    Intel Core temperature monitor
author:         Rudolf Marek <r.marek@assembler.cz>
srcversion:     ACC9B44AC9ED676294B7A11
depends:        hwmon
vermagic:       2.6.18-128.1.6.el5 SMP mod_unload gcc-4.1

# modinfo /lib/modules/2.6.18-194.el5/kernel/drivers/hwmon/coretemp.ko
filename:       /lib/modules/2.6.18-194.el5/kernel/drivers/hwmon/coretemp.ko
license:        GPL
description:    Intel Core temperature monitor
author:         Rudolf Marek <r.marek@assembler.cz>
srcversion:     4CF81EA50B65F53C763FEC5
depends:        hwmon
vermagic:       2.6.18-194.el5 SMP mod_unload gcc-4.1
module_sig:     883f3504bb6453c596239a507de7fd1126a2809f7080e696af5e76b0b6ebc63e5c2d4e9bc39b65310a0b8fa28d0a1cc7272f758d8c79f53cc99837f3781

That is sad.

Comment 2 Gerrit Slomma 2010-06-12 14:04:17 UTC
Applies to following CPUs

# grep "model name" /proc/cpuinfo
model name      : Intel(R) Xeon(R) CPU           L5408  @ 2.13GHz
model name      : Intel(R) Xeon(R) CPU           L5408  @ 2.13GHz
model name      : Intel(R) Xeon(R) CPU           L5408  @ 2.13GHz
model name      : Intel(R) Xeon(R) CPU           L5408  @ 2.13GHz
model name      : Intel(R) Xeon(R) CPU           L5408  @ 2.13GHz
model name      : Intel(R) Xeon(R) CPU           L5408  @ 2.13GHz
model name      : Intel(R) Xeon(R) CPU           L5408  @ 2.13GHz
model name      : Intel(R) Xeon(R) CPU           L5408  @ 2.13GHz

# grep "model name" /proc/cpuinfo
model name      : Intel(R) Core(TM)2 Quad CPU    Q9550  @ 2.83GHz
model name      : Intel(R) Core(TM)2 Quad CPU    Q9550  @ 2.83GHz
model name      : Intel(R) Core(TM)2 Quad CPU    Q9550  @ 2.83GHz
model name      : Intel(R) Core(TM)2 Quad CPU    Q9550  @ 2.83GHz

Comment 5 David Kovalsky 2010-08-16 14:45:58 UTC

*** This bug has been marked as a duplicate of bug 559228 ***


Note You need to log in before you can comment on or make changes to this bug.