Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595378 - Add support for using libvirt drivers directly from fence-virt w/o need for fence-virtd
Summary: Add support for using libvirt drivers directly from fence-virt w/o need for f...
Keywords:
Status: CLOSED DUPLICATE of bug 590696
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fence-virt
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Lon Hohberger
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 568553 (view as bug list)
Depends On: 595380 610811
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-24 13:49 UTC by Perry Myers
Modified: 2010-07-02 13:48 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-02 13:47:39 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Perry Myers 2010-05-24 13:49:58 UTC
Description of problem:
Right now fence-virt works by sending a fencing request to fence-virtd and then fence-virtd sends the request to the correct host.  This is fine for kvm based deployments.

But we need a way for fence-virt to use other libvirt drivers like ESX and on ESX hosts we can't use a fence-virtd.  So fence-virt should know to use libvirt driver for ESX/VirtualCenter when deployed on ESX hosts.

This is dependent on adding support for VirtualCenter into the libvirt driver.

Comment 1 Perry Myers 2010-05-24 13:54:10 UTC
*** Bug 568553 has been marked as a duplicate of this bug. ***

Comment 2 Perry Myers 2010-07-02 13:47:39 UTC

*** This bug has been marked as a duplicate of bug 590696 ***


Note You need to log in before you can comment on or make changes to this bug.