Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595353 - ds9-6.2 is available
Summary: ds9-6.2 is available
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: ds9
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 573808 (view as bug list)
Depends On: 663196
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-24 12:44 UTC by Upstream Release Monitoring
Modified: 2013-01-26 22:57 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-26 22:57:29 UTC


Attachments (Terms of Use)

Description Upstream Release Monitoring 2010-05-24 12:44:47 UTC
Latest upstream release: 6.1
Current version in Fedora Rawhide: 5.7
URL: http://hea-www.harvard.edu/RD/ds9/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring

Comment 1 Sergio Pascual 2010-07-16 14:05:11 UTC
*** Bug 573808 has been marked as a duplicate of this bug. ***

Comment 2 Upstream Release Monitoring 2010-10-16 10:09:23 UTC
Latest upstream release: 6.2
Current version in Fedora Rawhide: 5.7
URL: http://hea-www.harvard.edu/RD/ds9/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring

Comment 3 Orion Poplawski 2010-10-20 16:04:04 UTC
Any hope of seeing this packaged?

Comment 4 Sergio Pascual 2010-10-23 14:59:24 UTC
It requires blt-3.0. It's still beta (or alpha). I will ask the blt maintainer if he is willing to create a package directly from CVS.

Comment 5 Robert Greimel 2011-04-27 11:46:22 UTC
It would really be nice if ds9 version 6.2 could be included with Fedora as the currently distributed version for example does not create working postscript files.

As the stumbling block seems to be the (experimental?) version of the blt package, could ds9 not be packaged with the needed version of blt compiled in ?

Comment 6 Sergio Pascual 2011-04-27 12:04:34 UTC
It's not only that blt is version 3.0. Last time I checked (a few weeks ago), saotk frame component didn't compile due to some weird macro usage in ast.h header.

Upstream compiles with gcc 4.4.It seems that the code doesn't compile with gcc 4.5

Comment 7 Orion Poplawski 2011-04-27 20:01:52 UTC
- 6.1 uses blt 2.4z, perhaps we could stick with that for now
- The ast issue appears to fixed with the makeh from ast 5.6.  There are still a number of bundled libraries in ds9, including ast.  I've get a version of an ast package here:

http://www.cora.nwra.com/~orion/fedora/ast.spec
http://www.cora.nwra.com/~orion/fedora/ast-5.6-1.fc14.src.rpm

Comment 8 Sergio Pascual 2011-04-28 09:49:16 UTC
So what we need is an ast package. Would you submit it for review?

Comment 9 Robert Greimel 2011-04-29 09:56:13 UTC
Just for information, I had a short email exchange with the developer and the beta version of ds9 available at http://hea-www.harvard.edu/RD/ds9/beta.html is now supposed to compile with gcc 4.5 (it seems to include ast-5.6-0)

Comment 10 Sergio Pascual 2011-04-29 10:52:30 UTC
(In reply to comment #9)
> Just for information, I had a short email exchange with the developer and the
> beta version of ds9 available at http://hea-www.harvard.edu/RD/ds9/beta.html is
> now supposed to compile with gcc 4.5 (it seems to include ast-5.6-0)

Yes, it mostly compiles. It gas some errors, but they apear in packages than would be removed during packaging (tcl, etc). But this version requires blt 3, and in fedora we have blt 2.4. That's still a problem

Comment 11 Orion Poplawski 2011-05-03 22:01:30 UTC
Submitted ast for review here: https://bugzilla.redhat.com/show_bug.cgi?id=701801
Will need some more work.

Comment 12 Orion Poplawski 2011-05-04 17:23:35 UTC
Also put up signal_ext for review at Bug 702077

Comment 13 Rahul Sundaram 2013-01-26 22:00:16 UTC
What is the status of this?


Note You need to log in before you can comment on or make changes to this bug.