Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595321 - Clam AntiVirus: Heap-based overflow, when processing malicious PDF file(s) [Fedora all]
Summary: Clam AntiVirus: Heap-based overflow, when processing malicious PDF file(s) [F...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: clamav
Version: 14
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nick Bebout
QA Contact: Fedora Extras Quality Assurance
URL: http://fedoraproject.org/wiki/Securit...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-24 11:31 UTC by Jan Lieskovsky
Modified: 2011-01-04 19:38 UTC (History)
7 users (show)

Fixed In Version: clamav-0.96.1-1401.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-04 19:38:33 UTC


Attachments (Terms of Use)

Description Jan Lieskovsky 2010-05-24 11:31:45 UTC
This is an automatically created tracking bug! It was created to ensure that one or more security vulnerabilities are fixed in affected Fedora versions.

For comments that are specific to the vulnerability please use bugs filed against "Security Response" product referenced in "Blocks" field.

bug #595318:
Clam AntiVirus: Heap-based overflow, when processing malicious PDF file(s)

When creating a Bodhi update request, please include the bug IDs of the respective parent bugs filed against the "Security Response" product. Please mention CVE ids in the RPM changelog when available.

Bodhi update submission link:
https://admin.fedoraproject.org/updates/new/?type_=security&bugs=595318

Please note: this issue affects multiple supported versions of Fedora.  Only one tracking bug has been filed; please only close it when all affected versions are fixed.

For more information see: http://fedoraproject.org/wiki/Security/TrackingBugs

Comment 1 Bug Zapper 2010-07-30 11:42:00 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Fedora Update System 2010-08-11 01:19:11 UTC
clamav-0.96.1-1401.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/clamav-0.96.1-1401.fc13

Comment 3 Fedora Update System 2010-08-11 01:22:30 UTC
clamav-0.96.1-1401.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/clamav-0.96.1-1401.fc14

Comment 4 Fedora Update System 2010-08-11 01:36:45 UTC
clamav-0.96.1-1401.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/clamav-0.96.1-1401.fc12

Comment 5 Fedora Update System 2010-08-11 07:27:36 UTC
clamav-0.96.1-1401.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update clamav'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/clamav-0.96.1-1401.fc12

Comment 6 Fedora Update System 2010-08-11 07:30:52 UTC
clamav-0.96.1-1401.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update clamav'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/clamav-0.96.1-1401.fc13

Comment 7 Fedora Update System 2010-08-19 01:07:01 UTC
clamav-0.96.1-1401.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Vincent Danen 2011-01-04 17:35:11 UTC
No updated packages were pushed to EPEL for this (they probably should have been done at the same time as Fedora).

Could you please push the latest clamav to EPEL4 and 5?  EPEL6 has an appropriate version (0.96.1).

Comment 9 Vincent Danen 2011-01-04 19:38:33 UTC
I've opened a separate bug for EPEL, so re-closing this.


Note You need to log in before you can comment on or make changes to this bug.