Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595191 - java-1.6.0-openjdk-plugin has broken symlink in /etc/alternatives
Summary: java-1.6.0-openjdk-plugin has broken symlink in /etc/alternatives
Keywords:
Status: CLOSED DUPLICATE of bug 602906
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Martin Matejovic
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-23 23:46 UTC by Brian Daniels
Modified: 2010-06-15 18:42 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-15 18:42:14 UTC


Attachments (Terms of Use)

Description Brian Daniels 2010-05-23 23:46:29 UTC
Description of problem:

On a standard install of Fedora 13 Beta 64bit, java applications do not work in FireFox.  In /etc/alternatives there is a broken symlink to the plugin:

/etc/alternatives/libjavaplugin.so.x86_64 -> /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaNPPlugin.so

which does not exist.


Recreating the symlink as follows corrects the problem:
ln -s /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaPlugin.so libjavaplugin.so.x86_64


Version-Release number of selected component (if applicable):
Fedora 13 Beta

Comment 1 Brian Daniels 2010-06-07 13:50:58 UTC
I installed another system from F13 release, and it did not have this issue.  My beta system was using 1:1.6.0.0-38.b18.fc13 from the updates-testing repo for some reason.  Removing java-1.6.0-openjdk and then reinstalling from the release repo corrected the problem.  The symlink points to /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaNPPlugin.so which is present.

Comment 2 Jason Farrell 2010-06-07 20:46:41 UTC
after running:  alternatives --remove libjavaplugin.so.x86_64 /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaNPPlugin.so

the symlink then correctly points to: /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaPlugin.so

the postinstall scriptlet for the plugin isn't removing the correct old path.

Comment 3 Peque 2010-06-15 15:16:15 UTC
Thanks, that helped me fixing the problem :-)

Comment 4 Jason Farrell 2010-06-15 18:42:14 UTC

*** This bug has been marked as a duplicate of bug 602906 ***


Note You need to log in before you can comment on or make changes to this bug.