Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595127 - Where are the wacom alignment tools?
Summary: Where are the wacom alignment tools?
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-wacom
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-23 13:48 UTC by Brian G. Anderson
Modified: 2010-06-29 06:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-29 06:13:49 UTC


Attachments (Terms of Use)

Description Brian G. Anderson 2010-05-23 13:48:28 UTC
Description of problem:
I'm trying to get my wacom cintiq 12cx tablet aligned so that the stylus matches the screen (the cintiq has its own screen so I see exactly where the cursor is in relation to to the stylus point).  The cursor doesn't track the sytlus exactly in that it's aligned in when the cursor is in the middle of the screen put starts to drift left on the left part of the screen, right on the right part of the screen, etc.

Searching I find the linuxwacom project that talks about various tools to debug and align wacom tablets (wacomcpl for example).  Fedora doesn't seem to supply these packages which makes it difficult to set up a tablet.

Can Fedora include these tools please?

Version-Release number of selected component (if applicable):
0.10.6-1.fc13

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Peter Hutterer 2010-05-30 23:52:16 UTC
The driver we ship is a fork of linuxwacom for X servers 1.7 and later. The other tools with the exception of xsetwacom weren't forked as part of the driver. If they are to live on, they should be living in their own repository.

So right now, we don't have wacomcpl in fedora because the wacomcpl version from linuxwacom doesn't work against the current driver. It's not just a simple matter of including it, it's a matter of spending time sifting through the wacomcpl code and fixing it to work again - for the limited benefit of having a tcl-based UI that doesn't integrate with the rest on the desktop.

A gnome tool is being worked on though, but that's not finished just yet. Sorry.


Note You need to log in before you can comment on or make changes to this bug.